ubuntu16.04 登陆后鼠标失效

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
zhb_edward
帖子: 3
注册时间: 2016-08-16 13:17
系统: ubuntu16.04
送出感谢: 0
接收感谢: 0

ubuntu16.04 登陆后鼠标失效

#1

帖子 zhb_edward » 2016-08-16 14:39

在ubuntu16.04 的登陆页面,鼠标是可以使用的。但是一旦登陆进去了,鼠标瞬间就失效了。我换成舍友的游戏鼠标却都可以使用,很奇怪。
我感觉是不是usb驱动不兼容的问题,本来想重装一下usb驱动的,但是搜了一下网上好像没有这样的教程。请大神指教,谢谢!
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 997 次
联系:

Re: ubuntu16.04 登陆后鼠标失效

#2

帖子 vickycq » 2016-08-16 16:07

1. 尝试切换到其它虚拟终端再切回来
2. 尝试重新加载模块 usbhid
3. 尝试永久更换鼠标
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
zhb_edward
帖子: 3
注册时间: 2016-08-16 13:17
系统: ubuntu16.04
送出感谢: 0
接收感谢: 0

Re: ubuntu16.04 登陆后鼠标失效

#3

帖子 zhb_edward » 2016-08-16 16:29

vickycq 写了:1. 尝试切换到其它虚拟终端再切回来
2. 尝试重新加载模块 usbhid
3. 尝试永久更换鼠标

从虚拟终端切回来还是不行。
请问如何重新加载usbhid,求教
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 997 次
联系:

Re: ubuntu16.04 登陆后鼠标失效

#4

帖子 vickycq » 2016-08-16 18:19

zhb_edward 写了:如何重新加载usbhid

代码: 全选

sudo modprobe -r usbhid && sudo modprobe usbhid
若有效并接受此为临时解决方案,可创建快捷键绑定到此命令,失效时按一下。或令其在登录进桌面时自动运行。

绑定 Windows徽标键+m 到此功能,无需输入密码
假设用户名为 edward
1.

代码: 全选

mkdir /home/edward/bin
echo "sudo /sbin/modprobe -r usbhid && sudo /sbin/modprobe usbhid" | tee /home/edward/bin/reload_usbhid
chmod +x /home/edward/bin/reload_usbhid
2. 运行 visudo 在文件末尾添加一行

代码: 全选

edward ALL = (root) NOPASSWD: /sbin/modprobe
3. 使用桌面环境的快捷键管理器绑定 Windows徽标键+m 到 /home/edward/bin/reload_usbhid


令其在登录进桌面时自动运行
使用桌面环境的自启管理添加上述脚本。根据实际情况,可增加一定的延时。例如将脚本内容更换为

代码: 全选

sleep 0.5; sudo /sbin/modprobe -r usbhid && sudo /sbin/modprobe usbhid
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
ysming0
帖子: 3
注册时间: 2016-10-07 22:12
系统: 16.04
送出感谢: 0
接收感谢: 0

Re: ubuntu16.04 登陆后鼠标失效

#5

帖子 ysming0 » 2016-10-07 22:36

感谢!已成功解决问题;
天使不哭!
帖子: 1
注册时间: 2017-05-14 10:55
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: ubuntu16.04 登陆后鼠标失效

#6

帖子 天使不哭! » 2017-05-14 10:56

桌面的自启在哪?我是小白!
头像
omaidb
帖子: 104
注册时间: 2010-06-13 4:04
送出感谢: 3 次
接收感谢: 1 次

Re: ubuntu16.04 登陆后鼠标失效

#7

帖子 omaidb » 2019-10-10 16:38

这段时间也频繁遇到这个问题……
无涯书生,Google一下
回复

回到 “常用硬件支持”