软件中心大不开 输入法不能选择是怎么回事啊?

为当前最终发行版之前的所有版本提供支持
回复
hwmbing11
帖子: 14
注册时间: 2006-06-24 9:06
送出感谢: 0
接收感谢: 0

软件中心大不开 输入法不能选择是怎么回事啊?

#1

帖子 hwmbing11 » 2012-07-30 9:12

终端显示
[email protected]:~$ sudo software-center
2012-07-31 09:02:30,736 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-07-31 09:02:30,762 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-07-31 09:02:31,243 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-07-31 09:02:42,685 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', '不支持该操作'
2012-07-31 09:02:57,897 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', '不支持该操作'
[email protected]:~$ sudo software-center
2012-07-31 09:03:21,199 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-07-31 09:03:21,204 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-07-31 09:03:21,480 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-07-31 09:03:33,359 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', '不支持该操作'
2012-07-31 09:03:34,897 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', '不支持该操作'
2012-07-31 09:03:59,570 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-07-31 09:03:59,570 - softwarecenter.db.database - INFO - reopen() database
2012-07-31 09:03:59,571 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
Traceback (most recent call last):
File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/viewswitcher.py", line 149, in config_view
pane = vm.set_active_view(view_id)
File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 149, in set_active_view
view_widget.init_view()
File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 145, in init_view
self.oneconf_handler = get_oneconf_handler(self.oneconf_viewpickler)
File "/usr/share/software-center/softwarecenter/backend/oneconfhandler/__init__.py", line 32, in get_oneconf_handler
oneconf_handler = OneConfHandler(oneconfviewpickler)
File "/usr/share/software-center/softwarecenter/backend/oneconfhandler/core.py", line 56, in __init__
self.oneconf = DbusConnect()
File "/usr/lib/python2.7/dist-packages/oneconf/dbusconnect.py", line 142, in __init__
HOSTS_OBJECT_NAME)
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 241, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 248, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 180, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 278, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/share/oneconf/oneconf-service exited with status 1
2012-07-31 09:07:10,898 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', '不支持该操作'
hwmbing11
帖子: 14
注册时间: 2006-06-24 9:06
送出感谢: 0
接收感谢: 0

Re: 软件中心大不开 输入法不能选择是怎么回事啊?

#2

帖子 hwmbing11 » 2012-07-30 9:14

在终端能打开 显示这个 但是好像没用处不能安装软件XWINDOWS点不开
头像
TeliuTe
论坛版主
帖子: 7556
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 30 次
接收感谢: 103 次
联系:

Re: 软件中心大不开 输入法不能选择是怎么回事啊?

#3

帖子 TeliuTe » 2012-07-30 10:38

用命令行装个新立得软件包管理器替代一下
hwmbing11
帖子: 14
注册时间: 2006-06-24 9:06
送出感谢: 0
接收感谢: 0

Re: 软件中心大不开 输入法不能选择是怎么回事啊?

#4

帖子 hwmbing11 » 2012-07-30 11:46

谢谢了 我感觉我系统XWINDOWS的权限出现问题了 用终端+sudo就能运行 直接就运行不了 好多程序都出这个问题了 语言 附加驱动 等等 不知道什么地方出现问题了 不过好像还是没有解决
回复

回到 “老旧版本支持”