求救命,执行dpkg -i *.deb

系统安装、升级讨论
版面规则
我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。
回复
天涯醉客
帖子: 2
注册时间: 2022-08-11 14:46
系统: ubuntu
送出感谢: 0
接收感谢: 0

求救命,执行dpkg -i *.deb

#1

帖子 天涯醉客 » 2022-08-11 15:19

下面是安装包的各个依赖问题的报错拷贝,我网上找了几天,百度上的各种解决办法试了一遍,系统都重装了七八遍了,现在是用虚拟机快照反复在试,没有一个能解决的,依赖包版本不对,降级也降不下来,有大佬帮忙看看有什么办法处理吗?我是小白,最好是有详细命令,我在虚拟机去试,谢谢谢!

dpkg: dependency problems prevent configuration of binutils-x86-64-linux-gnu:
binutils-x86-64-linux-gnu depends on libc6 (>= 2.27); however:
Package libc6:amd64 is not installed.

dpkg: error processing package binutils-x86-64-linux-gnu (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of binutils-x86-64-linux-gnu-dbg:
binutils-x86-64-linux-gnu-dbg depends on binutils-x86-64-linux-gnu (= 2.35.2-2); however:
Package binutils-x86-64-linux-gnu is not configured yet.

dpkg: error processing package binutils-x86-64-linux-gnu-dbg (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cpp-9:
cpp-9 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package cpp-9 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of g++-9:
g++-9 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package g++-9 (--install):
dependency problems - leaving unconfigured
Setting up gcc-10-base:amd64 (10.3.0-1ubuntu1~20.04) ...
dpkg: dependency problems prevent configuration of gcc-9:
gcc-9 depends on cpp-9 (= 9.3.0-22); however:
Package cpp-9 is not configured yet.
gcc-9 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package gcc-9 (--install):
dependency problems - leaving unconfigured
Setting up gcc-9-base:amd64 (9.3.0-22) ...
dpkg: dependency problems prevent configuration of libasan5:amd64:
libasan5:amd64 depends on libc6 (>= 2.23); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libasan5:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libatomic1:amd64:
libatomic1:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libatomic1:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libatomic1:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbinutils:amd64:
libbinutils:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libbinutils:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
libc6-dev:amd64 depends on libc6 (= 2.31-0ubuntu9); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libc6-dev:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcc1-0:amd64:
libcc1-0:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libcc1-0:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libcc1-0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
libc-dev-bin depends on libc6 (>> 2.31); however:
Package libc6:amd64 is not installed.
libc-dev-bin depends on libc6 (<< 2.32); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libc-dev-bin (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcrypt-dev:amd64:
libcrypt-dev:amd64 depends on libcrypt1 (= 1:4.4.10-10ubuntu4); however:
Version of libcrypt1:amd64 on system is 1:4.4.27-1.

dpkg: error processing package libcrypt-dev:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libctf0:amd64:
libctf0:amd64 depends on libbinutils (= 2.35.2-2); however:
Package libbinutils:amd64 is not configured yet.
libctf0:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libctf0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libctf0-dbg:amd64:
libctf0-dbg:amd64 depends on libctf0 (= 2.35.2-2); however:
Package libctf0:amd64 is not configured yet.

dpkg: error processing package libctf0-dbg:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libctf-nobfd0:amd64:
libctf-nobfd0:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libctf-nobfd0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libctf-nobfd0-dbg:amd64:
libctf-nobfd0-dbg:amd64 depends on libctf-nobfd0 (= 2.35.2-2); however:
Package libctf-nobfd0:amd64 is not configured yet.

dpkg: error processing package libctf-nobfd0-dbg:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgcc-9-dev:amd64:
libgcc-9-dev:amd64 depends on libatomic1 (>= 9.3.0-22); however:
Package libatomic1:amd64 is not configured yet.
libgcc-9-dev:amd64 depends on libasan5 (>= 9.3.0-22); however:
Package libasan5:amd64 is not configured yet.

dpkg: error processing package libgcc-9-dev:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgomp1:amd64:
libgomp1:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libgomp1:amd64 depends on libc6 (>= 2.17); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libgomp1:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libisl23:amd64:
libisl23:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libisl23:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libitm1:amd64:
libitm1:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libitm1:amd64 depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libitm1:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblsan0:amd64:
liblsan0:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
liblsan0:amd64 depends on libc6 (>= 2.17); however:
Package libc6:amd64 is not installed.

dpkg: error processing package liblsan0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmpc3:amd64:
libmpc3:amd64 depends on libc6 (>= 2.4); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libmpc3:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libquadmath0:amd64:
libquadmath0:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libquadmath0:amd64 depends on libc6 (>= 2.23); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libquadmath0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libseccomp2:amd64:
libseccomp2:amd64 depends on libc6 (>= 2.4); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libseccomp2:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++-9-dev:amd64:
libstdc++-9-dev:amd64 depends on libgcc-9-dev (= 9.3.0-22); however:
Package libgcc-9-dev:amd64 is not configured yet.
libstdc++-9-dev:amd64 depends on libc6-dev (>= 2.13-5); however:
Package libc6-dev:amd64 is not configured yet.

dpkg: error processing package libstdc++-9-dev:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtsan0:amd64:
libtsan0:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libtsan0:amd64 depends on libc6 (>= 2.23); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libtsan0:amd64 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libubsan1:amd64:
libubsan1:amd64 depends on gcc-10-base (= 10.2.1-6); however:
Version of gcc-10-base:amd64 on system is 10.3.0-1ubuntu1~20.04.
libubsan1:amd64 depends on libc6 (>= 2.17); however:
Package libc6:amd64 is not installed.

dpkg: error processing package libubsan1:amd64 (--install):
dependency problems - leaving unconfigured
Setting up linux-libc-dev:amd64 (5.4.0-100.113) ...
dpkg: dependency problems prevent configuration of make:
make depends on libc6 (>= 2.27); however:
Package libc6:amd64 is not installed.

dpkg: error processing package make (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of manpages-dev:
manpages (5.10-1ubuntu1) breaks manpages-dev (<< 5.09-2) and is installed.
Version of manpages-dev to be configured is 5.05-1.

dpkg: error processing package manpages-dev (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unzip:
unzip depends on libc6 (>= 2.14); however:
Package libc6:amd64 is not installed.

dpkg: error processing package unzip (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of binutils:
binutils depends on libbinutils (= 2.35.2-2); however:
Package libbinutils:amd64 is not configured yet.
binutils depends on binutils-x86-64-linux-gnu (= 2.35.2-2); however:
Package binutils-x86-64-linux-gnu is not configured yet.

dpkg: error processing package binutils (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cpp:
cpp depends on cpp-9 (>= 9.3.0-3~); however:
Package cpp-9 is not configured yet.

dpkg: error processing package cpp (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of g++:
g++ depends on cpp (= 4:9.3.0-1ubuntu2); however:
Package cpp is not configured yet.
g++ depends on g++-9 (>= 9.3.0-3~); however:
Package g++-9 is not configured yet.
g++ depends on gcc-9 (>= 9.3.0-3~); however:
Package gcc-9 is not configured yet.

dpkg: error processing package g++ (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcc:
gcc depends on cpp (= 4:9.3.0-1ubuntu2); however:
Package cpp is not configured yet.
gcc depends on gcc-9 (>= 9.3.0-3~); however:
Package gcc-9 is not configured yet.

dpkg: error processing package gcc (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libc6_2.31-0ubuntu9_amd64.deb
binutils-x86-64-linux-gnu
binutils-x86-64-linux-gnu-dbg
cpp-9
g++-9
gcc-9
libasan5:amd64
libatomic1:amd64
libbinutils:amd64
libc6-dev:amd64
libcc1-0:amd64
libc-dev-bin
libcrypt-dev:amd64
libctf0:amd64
libctf0-dbg:amd64
libctf-nobfd0:amd64
libctf-nobfd0-dbg:amd64
libgcc-9-dev:amd64
libgomp1:amd64
libisl23:amd64
libitm1:amd64
liblsan0:amd64
libmpc3:amd64
libquadmath0:amd64
libseccomp2:amd64
libstdc++-9-dev:amd64
libtsan0:amd64
libubsan1:amd64
make
manpages-dev
unzip
binutils
cpp
g++
gcc
头像
astolia
论坛版主
帖子: 5825
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 1012 次

Re: 求救命,执行dpkg -i *.deb

#2

帖子 astolia » 2022-08-11 18:08

你为什么要dpkg -i *.deb,从哪里看到需要这么做的?是在哪个目录下执行的?
天涯醉客
帖子: 2
注册时间: 2022-08-11 14:46
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 求救命,执行dpkg -i *.deb

#3

帖子 天涯醉客 » 2022-08-11 18:16

要把文件夹下面的deb都安装一下
8357m
帖子: 4
注册时间: 2021-07-21 18:03
系统: Ubuntu
送出感谢: 1 次
接收感谢: 0

Re: 求救命,执行dpkg -i *.deb

#4

帖子 8357m » 2022-08-14 14:42

dpkg安装完ubuntu天生就能正常使用,从来没有遇到过问题。
回复