(A卡A友闭源帖---A卡为奥运而生中国加油)完善修改12.04的ATI驱动安装(期待12.10的马上来临)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
稻田雨
帖子: 21
注册时间: 2012-02-12 21:56
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#77

帖子 稻田雨 » 2012-02-14 21:07

不能成功呢。按照你的一步一步装下来,重启后进不了系统,提示“Ubuntu is running in low graphic mode”.
我装的是12.04 X64的,驱动是ATI12。机器是acer 4820TG
头像
wchl09
帖子: 22
注册时间: 2011-02-22 16:05
送出感谢: 0
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#78

帖子 wchl09 » 2012-02-15 10:31

刚开始下载时提示无法解析主机,看了半天终于发现原来把源地址写错了,中间出现了几个点,找了以下因该是复制时浏览器显示不全造成的 :em06
稻田雨
帖子: 21
注册时间: 2012-02-12 21:56
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#79

帖子 稻田雨 » 2012-02-15 13:41

我现在可以进系统,并且已经成功按上ATI驱动,不过是开源的。
关键是在BIOS里设置,把显卡的可切换选项改为另一项!这点很重要,不然的话开源驱动装了也不能够发挥作用。
至于楼主的方法我是在显卡设置为可切换的情况下安装的,一直没有成功。现在先不试了,不要又开不了机了
Kenfly
帖子: 2
注册时间: 2012-01-15 11:47
送出感谢: 0
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#80

帖子 Kenfly » 2012-02-16 10:28

kanyu1234
我的也是A卡,按照你的教程成功装了12.04 64-bit后,很多软件都表现不正常,比如输入法设置失常,docky也崩了,必须重新装,经常跳出一些bug报告,比如gnome-control-center崩溃的报告
最重要的是界面显示卡卡的,拖动窗口一闪一闪的,看旧了有点晕眩,点击一点docky会产生背景殘影,以前也是这样的问题,但删了显卡驱动后就表现很流畅,一装上显卡驱动就又一卡一卡的。上stackoverflow问了也说解决不了的问题。请问你的机子表现正常吗?拖动有一闪一闪吗?
danver89
帖子: 5
注册时间: 2011-12-29 9:43
送出感谢: 0
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#81

帖子 danver89 » 2012-02-17 12:44

执行到这里出错:
创建.deb的安装包
sudo sh ./amd-driver-installer-12-1-x86.x86_64.run --buildpkg Ubuntu/oneiric

安装生成的包:
sudo dpkg -i fglrx*.deb


显示信息如下:
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.uDyUP9
root@ubuntu:/home/********/catalyst12.1# sudo dpkg -i fglrx*.deb
dpkg:处理 fglrx*.deb (--install)时出错:
无法访问归档文件: 没有那个文件或目录
在处理时有错误发生:
fglrx*.deb
头像
wswz315
帖子: 256
注册时间: 2010-04-12 13:39
来自: 北京
送出感谢: 21 次
接收感谢: 1 次
联系:

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#82

帖子 wswz315 » 2012-02-17 15:01

mark。有集成ati。
头像
东方为明
帖子: 38
注册时间: 2011-02-28 18:12
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#83

帖子 东方为明 » 2012-02-19 0:59

正在安装,谢谢楼主了。帖子写的确实很简单易懂,连我这中菜鸟都可以按步骤进行。希望一会儿下载好后能够成功 :em11
为什么我的电脑总有问题,很少人遇到的问题。。。。。
头像
东方为明
帖子: 38
注册时间: 2011-02-28 18:12
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#84

帖子 东方为明 » 2012-02-19 2:41

悲剧的事情还是发生了 :em20
之前的安装还算顺利,但是安装到【安装生成的包:sudo dpkg -i fglrx*.deb】步骤时却出现问题,系统提示如下:

fengyanhao@fengyanhao-HP-ProBook-4321s:~/catalyst12.1$ sudo dpkg -i fglrx*.deb
选中了曾被取消选择的软件包 fglrx。
(正在读取数据库 ... 系统当前共安装有 182759 个文件和目录。)
正在解压缩 fglrx (从 fglrx_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-amdcccle。
正在解压缩 fglrx-amdcccle (从 fglrx-amdcccle_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-dev。
正在解压缩 fglrx-dev (从 fglrx-dev_8.930-0ubuntu1_amd64.deb) ...
dpkg:依赖关系问题使得 fglrx 的配置工作不能继续:
fglrx 依赖于 lib32gcc1;然而:
未安装软件包 lib32gcc1。
fglrx 依赖于 libc6-i386;然而:
未安装软件包 libc6-i386。
dpkg:处理 fglrx (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-amdcccle 的配置工作不能继续:
fglrx-amdcccle 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-amdcccle (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-dev 的配置工作不能继续:
fglrx-dev 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-dev (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 ureadahead 的触发器...
在处理时有错误发生:
fglrx
fglrx-amdcccle
fglrx-dev

好像还有一些东西没有配置,请问该怎么解决 :em06 :em06
为什么我的电脑总有问题,很少人遇到的问题。。。。。
头像
东方为明
帖子: 38
注册时间: 2011-02-28 18:12
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#85

帖子 东方为明 » 2012-02-19 9:19

发现自己还是应该多多尝试才行啊
lib32gcc1和libc6-i386都可以在软件中心中搜索并下载,后面得依赖问题控制问题等都是因为缺这两个东西造成的,下载下来安装上后问题自然就解决了 :em11
还有一点不明白的就是楼主的【生成配置文件:sudo aticonfig --initial -f】步骤和【防止配置未生效:sudo aticonfig --input=/etc/X11/xorg.conf --tls=1】步骤我并没有成功,但是跳过这两步后重启发现在检查的时候都通过了,信息如下:
fglrxinfo
fengyanhao@fengyanhao-HP-ProBook-4321s:~$ fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 4500 Series
OpenGL version string: 3.3.11399 Compatibility Profile Context

fgl_glxgears
fengyanhao@fengyanhao-HP-ProBook-4321s:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
4862 frames in 5.0 seconds = 972.400 FPS
5238 frames in 5.0 seconds = 1047.600 FPS
5241 frames in 5.0 seconds = 1048.200 FPS
5232 frames in 5.0 seconds = 1046.400 FPS
5235 frames in 5.0 seconds = 1047.000 FPS

aticonfig --pxl #
fengyanhao@fengyanhao-HP-ProBook-4321s:~$ aticonfig --pxl #
PowerXpress: Integrated GPU is active (Power-Saving mode).

虽然本子的风扇声依然很大(主要是因为HP的散热太差了,win7下的风扇声也不小),但是和之前用集显的情况相比已经还算是不错的了,起码不用的时候风扇声会小很多。希望以后不要再出什么悲剧的事情 :em11
为什么我的电脑总有问题,很少人遇到的问题。。。。。
稻田雨
帖子: 21
注册时间: 2012-02-12 21:56
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#86

帖子 稻田雨 » 2012-02-19 17:42

东方为明 写了:悲剧的事情还是发生了 :em20
之前的安装还算顺利,但是安装到【安装生成的包:sudo dpkg -i fglrx*.deb】步骤时却出现问题,系统提示如下:

fengyanhao@fengyanhao-HP-ProBook-4321s:~/catalyst12.1$ sudo dpkg -i fglrx*.deb
选中了曾被取消选择的软件包 fglrx。
(正在读取数据库 ... 系统当前共安装有 182759 个文件和目录。)
正在解压缩 fglrx (从 fglrx_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-amdcccle。
正在解压缩 fglrx-amdcccle (从 fglrx-amdcccle_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-dev。
正在解压缩 fglrx-dev (从 fglrx-dev_8.930-0ubuntu1_amd64.deb) ...
dpkg:依赖关系问题使得 fglrx 的配置工作不能继续:
fglrx 依赖于 lib32gcc1;然而:
未安装软件包 lib32gcc1。
fglrx 依赖于 libc6-i386;然而:
未安装软件包 libc6-i386。
dpkg:处理 fglrx (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-amdcccle 的配置工作不能继续:
fglrx-amdcccle 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-amdcccle (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-dev 的配置工作不能继续:
fglrx-dev 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-dev (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 ureadahead 的触发器...
在处理时有错误发生:
fglrx
fglrx-amdcccle
fglrx-dev

好像还有一些东西没有配置,请问该怎么解决 :em06 :em06
你装完系统后,有没有在软件更新里换源?
一般要先换源,比如说选163或者别的最快的源,然后更新(这个很重要),因为创建软件包的功能在更新后才会被安装,同时依赖的问题也会解决。
PS:如果用ATI的run的话,直接双击也能打开,然后进入和windows一样的可是窗口了!最后别忘了设置aticonf那一步。可能还得在重启后把BIOS的显卡设置为独显!(我的就是,不设置就报错,说显卡在底分辨率下运行)
头像
东方为明
帖子: 38
注册时间: 2011-02-28 18:12
送出感谢: 1 次
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#87

帖子 东方为明 » 2012-02-19 19:23

稻田雨 写了:
东方为明 写了:悲剧的事情还是发生了 :em20
之前的安装还算顺利,但是安装到【安装生成的包:sudo dpkg -i fglrx*.deb】步骤时却出现问题,系统提示如下:

fengyanhao@fengyanhao-HP-ProBook-4321s:~/catalyst12.1$ sudo dpkg -i fglrx*.deb
选中了曾被取消选择的软件包 fglrx。
(正在读取数据库 ... 系统当前共安装有 182759 个文件和目录。)
正在解压缩 fglrx (从 fglrx_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-amdcccle。
正在解压缩 fglrx-amdcccle (从 fglrx-amdcccle_8.930-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 fglrx-dev。
正在解压缩 fglrx-dev (从 fglrx-dev_8.930-0ubuntu1_amd64.deb) ...
dpkg:依赖关系问题使得 fglrx 的配置工作不能继续:
fglrx 依赖于 lib32gcc1;然而:
未安装软件包 lib32gcc1。
fglrx 依赖于 libc6-i386;然而:
未安装软件包 libc6-i386。
dpkg:处理 fglrx (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-amdcccle 的配置工作不能继续:
fglrx-amdcccle 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-amdcccle (--install)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 fglrx-dev 的配置工作不能继续:
fglrx-dev 依赖于 fglrx;然而:
软件包 fglrx 尚未配置。
dpkg:处理 fglrx-dev (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 ureadahead 的触发器...
在处理时有错误发生:
fglrx
fglrx-amdcccle
fglrx-dev

好像还有一些东西没有配置,请问该怎么解决 :em06 :em06
你装完系统后,有没有在软件更新里换源?
一般要先换源,比如说选163或者别的最快的源,然后更新(这个很重要),因为创建软件包的功能在更新后才会被安装,同时依赖的问题也会解决。
PS:如果用ATI的run的话,直接双击也能打开,然后进入和windows一样的可是窗口了!最后别忘了设置aticonf那一步。可能还得在重启后把BIOS的显卡设置为独显!(我的就是,不设置就报错,说显卡在底分辨率下运行)
源是之前看秀才的视频教程时就已经改过来了
设置aticonfi那一步我做了,但是貌似出问题了,以下是当时的代码:
fengyanhao@fengyanhao-HP-ProBook-4321s:~/catalyst12.1$ sudo aticonfig --initial -f
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-0
生成配置文件和防止配置未生效我也按照帖子上说的做了,就是也把代码复制进去执行了,代码是下面这个:
fengyanhao@fengyanhao-HP-ProBook-4321s:~/catalyst12.1$ sudo aticonfig --input=/etc/X11/xorg.conf --tls=1
Warning: Option 'UseFastTLS' doesn't affect running session.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.fglrx-3

BIOS里面的显卡切换选项我倒是还没有切换成集显的,因为平时有些东西还得回到win7下完成,所以直接就换成集显就不是很方便了,所以我就没有动他
听说按不好的话经常会出现开机进不去或者报错之类的,但是我的现在貌似还没有遇到这样的问题,而且我也找到了ATI的run并且可以打开,风扇声明显小了不少(确定风扇还在转动)。除了有时候在切换界面时会出现一些花边的现象外,基本上到现在还都没有碰到过问题。弄拙成巧了啊 :em06 :em06
为什么我的电脑总有问题,很少人遇到的问题。。。。。
xdata
帖子: 2
注册时间: 2011-05-28 19:05
送出感谢: 0
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#88

帖子 xdata » 2012-02-21 12:48

:em06

楼主要是新手都不算的话 ,那我连个屁都不是了

这么厉害的帖子还有“高人”在说三道四啊,
看来也高不了哪里去了,
头像
寒声碎
帖子: 1723
注册时间: 2009-07-31 16:50
送出感谢: 3 次
接收感谢: 4 次
联系:

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#89

帖子 寒声碎 » 2012-02-25 10:57

楼主牛人
ATI radeon 9550前两天在debian里面安装官方驱动失败。现在换成ubuntu11.10了,正在考虑要不要再安装。
l-zp
帖子: 6
注册时间: 2012-02-24 13:17
送出感谢: 0
接收感谢: 0

Re: (ATI显卡本菜鸟发的贴,希望对你们有帮助---元宵节祝大家全家团圆)更新Ubuntu12.04的ATI驱动傻瓜

#90

帖子 l-zp » 2012-02-26 21:05

make更新完来12.04后试试~~
回复

回到 “常用硬件支持”