(A卡A友闭源帖---A卡为奥运而生中国加油)完善修改12.04的ATI驱动安装(期待12.10的马上来临)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
kwind
帖子: 2
注册时间: 2011-10-22 12:48
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#31

帖子 kwind » 2011-12-01 22:25

感谢lz,哈哈,今天早上装catalyst的时候出问题了,装完后就进入不了unity都界面,只有恢复xorg.conf
想不到今晚看到此帖啦...迟下再试试...thx :em11
头像
iknewilovedyou
帖子: 41
注册时间: 2010-03-03 19:16
来自: 北京
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(更新:加入笔记本关闭独显,只用核显))---临时置顶

#32

帖子 iknewilovedyou » 2011-12-03 11:06

kanyu1234 写了:
wavechan 写了:双显卡没成功!每次开机手动关另一个显卡。
双显卡的那个方法,经常无缘无故失效。。。请大侠无视他吧!!!

那是给有缘人的! :em04
难道就没有解决的吗? :em20
我是新手菜鸟~~~
perfume008
帖子: 1
注册时间: 2011-01-10 16:49
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#33

帖子 perfume008 » 2011-12-05 22:40

按照楼主的方法安装闭源驱动时,出现无法找到软件包dh-modaliases。不知道什么原因呢?
DirtyAss
帖子: 4
注册时间: 2011-12-11 9:48
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#34

帖子 DirtyAss » 2011-12-11 10:06

楼主我按照你的方法一步一步来,到了后面的创建单核GPU xorg.cnof时出错。
输入sudo aticonfig --initial -f
返回结果是:
Uninitialised file found, configuring.
Using xorg.conf
Saving back-up to xorg.conf.fglrx-3
跟着在X11的文件夹里生成新的文件xorg.conf.fglrx-3(我已经输入过几次“sudo aticonfig --initial -f” 所以已经生成了0-3的相同的xorg.conf.fglrx文件。)
xorg.conf里面的内容
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

xorg.conf.fglrx-3文件内容:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "0-CRT2"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "PreferredMode" "1280x1024"
Option "TargetRefresh" "75"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "Monitor-CRT2" "0-CRT2"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

我用的是官方最新的闭源驱动11-10的不是楼主的11-9。我的显卡是ATI Radeon HD 5670。安装驱动后没有显示楼主说的新加的选项。请问这是什么问题。
头像
cxbii
帖子: 492
注册时间: 2011-02-06 1:38
送出感谢: 11 次
接收感谢: 5 次

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#35

帖子 cxbii » 2011-12-11 11:35

:em06 应该能解决我的问题
bygaoyu
帖子: 1
注册时间: 2011-03-13 21:57
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#36

帖子 bygaoyu » 2011-12-11 23:48

我是按照贴上做的
显卡是ati6470,驱动闭源的
怎么vainfo,跟帖子上的不一样,是怎么回事,求解答
libva: libva version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva error: /usr/lib/dri/fglrx_drv_video.so init failed
libva: va_openDriver() returns 1
vaInitialize failed with error code 1 (operation failed),exit
sigualws
帖子: 2
注册时间: 2011-03-24 2:15
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#37

帖子 sigualws » 2011-12-13 1:29

好强阿
折腾好久之后 gnome3还是闪
终于今天 取消在系统托盘显示输入法 就解决
这些问题真够奇怪的

感谢楼主
kanyu1234
帖子: 66
注册时间: 2011-10-21 12:07
送出感谢: 8 次
接收感谢: 4 次

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#38

帖子 kanyu1234 » 2011-12-23 12:47

perfume008 写了:按照楼主的方法安装闭源驱动时,出现无法找到软件包dh-modaliases。不知道什么原因呢?
请注意每一步骤细心、小心!

请看安装闭源驱动的第一步:

最后一个dh-modaliases。。。。是否漏打了?下载没成功?

祝你圣诞愉快!

另附dh-modaliases.deb下载包。。。。版本可能有点旧!呵呵!
附件
dh-modaliases_0.9.6-0ubuntu1_all.deb
dh-modaliases.deb
(8.7 KiB) 下载 68 次
kanyu1234
帖子: 66
注册时间: 2011-10-21 12:07
送出感谢: 8 次
接收感谢: 4 次

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#39

帖子 kanyu1234 » 2011-12-23 12:51

DirtyAss 写了:楼主我按照你的方法一步一步来,到了后面的创建单核GPU xorg.cnof时出错。
输入sudo aticonfig --initial -f
返回结果是:
Uninitialised file found, configuring.
Using xorg.conf
Saving back-up to xorg.conf.fglrx-3
跟着在X11的文件夹里生成新的文件xorg.conf.fglrx-3(我已经输入过几次“sudo aticonfig --initial -f” 所以已经生成了0-3的相同的xorg.conf.fglrx文件。)
xorg.conf里面的内容
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

xorg.conf.fglrx-3文件内容:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "0-CRT2"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "PreferredMode" "1280x1024"
Option "TargetRefresh" "75"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "Monitor-CRT2" "0-CRT2"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

我用的是官方最新的闭源驱动11-10的不是楼主的11-9。我的显卡是ATI Radeon HD 5670。安装驱动后没有显示楼主说的新加的选项。请问这是什么问题。
文件未发现。。。。这个我这个笨鸟无法解答了!建议彻底干净的卸载显卡驱动,重新安装一下!
kanyu1234
帖子: 66
注册时间: 2011-10-21 12:07
送出感谢: 8 次
接收感谢: 4 次

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#40

帖子 kanyu1234 » 2011-12-23 12:54

bygaoyu 写了:我是按照贴上做的
显卡是ati6470,驱动闭源的
怎么vainfo,跟帖子上的不一样,是怎么回事,求解答
libva: libva version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva error: /usr/lib/dri/fglrx_drv_video.so init failed
libva: va_openDriver() returns 1
vaInitialize failed with error code 1 (operation failed),exit
fglrx_drv_video动态链接库错误,硬解失败有问题啊!建议彻底删除显卡驱动,按照步骤,重新安装!
kanyu1234
帖子: 66
注册时间: 2011-10-21 12:07
送出感谢: 8 次
接收感谢: 4 次

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#41

帖子 kanyu1234 » 2011-12-23 12:56

sigualws 写了:好强阿
折腾好久之后 gnome3还是闪
终于今天 取消在系统托盘显示输入法 就解决
这些问题真够奇怪的

感谢楼主
互相帮助,圣诞愉快!删除后有时开机又会出现输入法删一下,冬天动动手锻炼锻炼!
头像
cikekid
帖子: 628
注册时间: 2008-11-28 13:57
系统: OSX/CentOS
送出感谢: 1 次
接收感谢: 5 次

Re: ati显卡的朋友来看看,希望对你们有帮助---我也是菜鸟,圣诞愉快!

#42

帖子 cikekid » 2011-12-23 13:34

好贴,LZ很用心,而且很谦虚

代码: 全选

sudo mount /dev/sda* /mnt/
sudo mount -t proc none /mnt/proc
sudo mount -o bind /dev /mnt/dev
sudo chroot /mnt/ /bin/bash
sudo apt-get install grub
sudo grub-install --no-floppy /dev/sda
POPPYboy
帖子: 1
注册时间: 2011-09-26 14:36
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望对你们有帮助---我也是菜鸟,圣诞愉快!

#43

帖子 POPPYboy » 2011-12-27 23:04

楼主的意思是先安装开源驱动,然后再安装闭源驱动?
头像
zue
帖子: 79
注册时间: 2008-03-22 23:49
来自: 北京
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望对你们有帮助---我也是菜鸟,圣诞愉快!

#44

帖子 zue » 2012-01-01 23:00

非常感谢LZ,按步骤做了一次性成功。 :em02 偶ATI radeon 6870显卡。
你想拥有什么,你就去追求什么
bayern00123
帖子: 10
注册时间: 2011-12-29 18:22
送出感谢: 0
接收感谢: 0

Re: ati显卡的朋友来看看,希望我的经历对你们有帮助!(11.27更新:gnome3闪屏解决小办法)---临时置顶

#45

帖子 bayern00123 » 2012-01-02 19:20

bygaoyu 写了:我是按照贴上做的
显卡是ati6470,驱动闭源的
怎么vainfo,跟帖子上的不一样,是怎么回事,求解答
libva: libva version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva error: /usr/lib/dri/fglrx_drv_video.so init failed
libva: va_openDriver() returns 1
vaInitialize failed with error code 1 (operation failed),exit
我跟你一样的问题啊,请问你怎么解决的?
回复

回到 “常用硬件支持”