求助,ubuntu18.04安装hp打印机扫描仪驱动

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
fcy232016
帖子: 2
注册时间: 2019-10-09 15:38
系统: ubuntu
送出感谢: 0
接收感谢: 0

求助,ubuntu18.04安装hp打印机扫描仪驱动

#1

帖子 fcy232016 » 2019-10-09 20:20

求助,我的电脑是ubuntu18.04,打印机用的是HP laserjet pro MFP M126a打印扫描一体机。现在打印机驱动已经装能使用了,但是扫描仪的驱动怎么都装不上。每次用hp-plugin安装的时候最后都会出Pyhon gobject/dbus may be not installed。我已经安装了dbus-python(python2.7/3.6)和gobject(python3.6)包,但是还是不管用。我的打印机驱动是hplip-3.19.6。是不是还要装什么别的包?谢谢
xenomorph0525
帖子: 409
注册时间: 2009-11-21 20:29
送出感谢: 8 次
接收感谢: 16 次

Re: 求助,ubuntu18.04安装hp打印机扫描仪驱动

#2

帖子 xenomorph0525 » 2019-10-09 21:49

fcy232016 写了:
2019-10-09 20:20
求助,我的电脑是ubuntu18.04,打印机用的是HP laserjet pro MFP M126a打印扫描一体机。现在打印机驱动已经装能使用了,但是扫描仪的驱动怎么都装不上。每次用hp-plugin安装的时候最后都会出Pyhon gobject/dbus may be not installed。我已经安装了dbus-python(python2.7/3.6)和gobject(python3.6)包,但是还是不管用。我的打印机驱动是hplip-3.19.6。是不是还要装什么别的包?谢谢
會不會它要你裝的是32bit包,但你裝的是64bit包?(或者反過來)
头像
Ping-Wu
帖子: 1163
注册时间: 2012-11-14 9:34
系统: Ubuntu 19.10
送出感谢: 3 次
接收感谢: 57 次

Re: 求助,ubuntu18.04安装hp打印机扫描仪驱动

#3

帖子 Ping-Wu » 2019-10-10 1:39

我们的经验,在 Ubuntu 18.04/19.04 里,如果 hplip 的版本太新常常会出现依赖的问题。我们从 19.10 开机后,直接由 Ubuntu repository 装就可以了:

代码: 全选

 sudo apt update && sudo install hplip hplip-gui
之后,执行 hp-setup 就可以自动装设 hp-plugin。
fcy232016
帖子: 2
注册时间: 2019-10-09 15:38
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 求助,ubuntu18.04安装hp打印机扫描仪驱动

#4

帖子 fcy232016 » 2019-10-10 9:44

Ping-Wu 写了:
2019-10-10 1:39
我们的经验,在 Ubuntu 18.04/19.04 里,如果 hplip 的版本太新常常会出现依赖的问题。我们从 19.10 开机后,直接由 Ubuntu repository 装就可以了:

代码: 全选

 sudo apt update && sudo install hplip hplip-gui
之后,执行 hp-setup 就可以自动装设 hp-plugin。
18.04自带的是hplip3.17 刚装好系统的时候打印机都不管用,我先从官网上下了个3.19.8 ,装好打印机管用了,但是找不到相关的plugin,只好又装了个3.19.6然后就一直装不上扫描仪了。
我用 hp-setup 试了,然后就依然使用3.19.6来认的打印机,我是不是应该直接装低版本的?
头像
Ping-Wu
帖子: 1163
注册时间: 2012-11-14 9:34
系统: Ubuntu 19.10
送出感谢: 3 次
接收感谢: 57 次

Re: 求助,ubuntu18.04安装hp打印机扫描仪驱动

#5

帖子 Ping-Wu » 2019-10-10 14:48

fcy232016 写了:
2019-10-10 9:44
Ping-Wu 写了:
2019-10-10 1:39
我们的经验,在 Ubuntu 18.04/19.04 里,如果 hplip 的版本太新常常会出现依赖的问题。我们从 19.10 开机后,直接由 Ubuntu repository 装就可以了:

代码: 全选

 sudo apt update && sudo install hplip hplip-gui
之后,执行 hp-setup 就可以自动装设 hp-plugin。
18.04自带的是hplip3.17 刚装好系统的时候打印机都不管用,我先从官网上下了个3.19.8 ,装好打印机管用了,但是找不到相关的plugin,只好又装了个3.19.6然后就一直装不上扫描仪了。
我用 hp-setup 试了,然后就依然使用3.19.6来认的打印机,我是不是应该直接装低版本的?
我查了一下,我们装设的版本是 hpli--3.18.4.run。 因为已很久没有使用 18.04 了,结果不敢保证。Good Luck!
头像
ahwad
帖子: 1059
注册时间: 2009-05-06 0:36
送出感谢: 1 次
接收感谢: 13 次

Re: 求助,ubuntu18.04安装hp打印机扫描仪驱动

#6

帖子 ahwad » 2019-10-10 17:02

我也是这个打印机,待会,试一试。。。。。
回复

回到 “常用硬件支持”