et没声音啊…我该怎么办?

游戏讨论
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: et没声音啊…我该怎么办?

#16

帖子 eexpress » 2011-02-16 15:09

Pulseaudio can emulate oss by using papsd, which probably is already installed.
Just run:

padsp /path/to/your/game
● 鸣学
头像
yjmwxwx
帖子: 50
注册时间: 2008-11-14 2:31
送出感谢: 0
接收感谢: 0

Re: et没声音啊…我该怎么办?

#17

帖子 yjmwxwx » 2011-02-16 15:38

http://www.hirntot.org/index.php?option ... Itemid=109

GOOGLE上找了下,不过我还是没成功,他里面有个字母错了好象是SDL_AUDIODRIVER="alsa" 。。

反正我是没成功,打算换UBUNTU10.04 :em20
头像
mark1991
帖子: 218
注册时间: 2007-02-12 19:46
送出感谢: 1 次
接收感谢: 1 次

Re: et没声音啊…我该怎么办?

#18

帖子 mark1991 » 2011-02-16 22:23

eexpress 写了:Pulseaudio can emulate oss by using papsd, which probably is already installed.
Just run:

padsp /path/to/your/game
前面说过了,我试了这个方法,说我的声卡不能这样。 也不知道是声卡真的不能, 还是哪里出了什么错……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: et没声音啊…我该怎么办?

#19

帖子 eexpress » 2011-02-17 9:26

● 鸣学
头像
yjmwxwx
帖子: 50
注册时间: 2008-11-14 2:31
送出感谢: 0
接收感谢: 0

Re: et没声音啊…我该怎么办?

#20

帖子 yjmwxwx » 2011-02-18 14:16

头像
mark1991
帖子: 218
注册时间: 2007-02-12 19:46
送出感谢: 1 次
接收感谢: 1 次

Re: et没声音啊…我该怎么办?

#21

帖子 mark1991 » 2011-02-20 14:08

用了一个 那个et-sdl-sound脚本,是有声音了。
今天偶然wine了一下windows版本,发现貌似完美解决了声音问题… 要不,就用wine直接跑算了?
这些用户感谢了作者 mark1991 于这个帖子:
q12we34r (2021-02-21 14:23)
评价: 3.7%
q12we34r
帖子: 1
注册时间: 2021-02-21 14:20
送出感谢: 1 次
接收感谢: 0

Re: et没声音啊…我该怎么办?

#22

帖子 q12we34r » 2021-02-21 14:23

mark1991 写了:
2011-02-20 14:08
用了一个 那个et-sdl-sound脚本,是有声音了。
今天偶然wine了一下windows版本,发现貌似完美解决了声音问题… 要不,就用wine直接跑算了?
咋么弄?
回复

回到 “游戏模拟器”