需要旧版软件或被移除软件的PKGBUILD,怎么办?

回复
头像
spectater
帖子: 665
注册时间: 2008-02-03 18:53
送出感谢: 0
接收感谢: 1 次

需要旧版软件或被移除软件的PKGBUILD,怎么办?

#1

帖子 spectater » 2009-11-09 12:01

http://www.linuxsir.org/bbs/thread194435.html

代码: 全选

需要某个软件包的旧版,最简单的方法是到http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/
看一下。点击最下面的<Show files using tag>旁边的按钮,连最最陈旧的版本的包的PKGBUILD都可以轻易的找到。

:em20
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#2

帖子 hubert_star » 2009-11-09 12:08

说的没错啊,怎么了?
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
头像
spectater
帖子: 665
注册时间: 2008-02-03 18:53
送出感谢: 0
接收感谢: 1 次

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#3

帖子 spectater » 2009-11-09 12:17

hubert_star 写了:说的没错啊,怎么了?
这个访问不了:
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/

:em20

最简单的方法是
麻烦一点的办法是什么? :em05
头像
pocoyo
论坛版主
帖子: 25877
注册时间: 2008-03-25 15:49
来自: 谁知道?
送出感谢: 5 次
接收感谢: 9 次
联系:

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#4

帖子 pocoyo » 2009-11-09 12:19

:em20
头像
HuntXu
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#5

帖子 HuntXu » 2009-11-09 14:11

svn checkout旧版的PKGBUILD
HUNT Unfortunately No Talent...
头像
xjpvictor
帖子: 2837
注册时间: 2007-08-22 15:55
系统: Archlinux
来自: 新加坡
送出感谢: 0
接收感谢: 9 次
联系:

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#6

帖子 xjpvictor » 2009-11-09 14:48

去wiki看下,有一些很久不更新的服务器的地址
Entschuldigung. Ich habe keine ahnung.
Secure with PGP: gpg --recv-keys 0x68b6e3d8
Fingerprint: 5556 517C F52F E402 DDF5 5400 6D30 F13E 68B6 E3D8
Towards A Sustainable Earth: Print Only When Necessary
头像
spectater
帖子: 665
注册时间: 2008-02-03 18:53
送出感谢: 0
接收感谢: 1 次

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#7

帖子 spectater » 2009-11-09 16:57

HuntXu 写了:svn checkout旧版的PKGBUILD
愿闻其详 :em01
头像
spectater
帖子: 665
注册时间: 2008-02-03 18:53
送出感谢: 0
接收感谢: 1 次

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#8

帖子 spectater » 2009-11-09 21:23

经过研究学习,我终于搞清楚了如何得到旧版软件或被移除软件的PKGBUILD。 :em11
头像
pocoyo
论坛版主
帖子: 25877
注册时间: 2008-03-25 15:49
来自: 谁知道?
送出感谢: 5 次
接收感谢: 9 次
联系:

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#9

帖子 pocoyo » 2009-11-10 13:17

ls怎么办的 也不说清楚..
14cheese
帖子: 4
注册时间: 2008-04-08 13:14
送出感谢: 0
接收感谢: 0

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#10

帖子 14cheese » 2009-11-12 21:35

或者可以用abs自己DIY一下PKGBUILD?
beruchtigte
帖子: 284
注册时间: 2007-12-30 13:17
送出感谢: 0
接收感谢: 0

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#11

帖子 beruchtigte » 2009-11-13 0:28

头像
soge
帖子: 449
注册时间: 2009-05-13 14:31
送出感谢: 0
接收感谢: 0

Re: 需要旧版软件或被移除软件的PKGBUILD,怎么办?

#12

帖子 soge » 2009-11-13 22:45

我用aur安装过一个旧的xf86-video-ati

代码: 全选

御风而行
回复

回到 “Arch发行版”