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Chapter 1

I

1.1 WOk E| LyX!

XA IR NABLEAFIE BIEX B2 B DR AR AL, A LyX A
23] BTEX - LyX B EH ARt R I — 0B WEIET A BTEX M - 9 T @R i A
LyX, @& ] — BRI .

TR& R IAE R E T A B A 5 F RO U IyX AR RESE 1, e
< RIS, FEBRIEEIA=DEAT o AR LRI H BB e T ah B ]
BE S FREERT, BT DMRANSARISRASCHERR - DyX & MOFHR B R, MR AR ZE
BRETHERZNRM: REESHINE -

PELBE RN E, THREZD WX REXREE, R BaErEr -

1.2 AKEFER

TEF IR Z AT WERSE 1 — R Introduction, AR EMRE T AU IR - SR
TRETRAMTENENLZE, BN eREEAREREE T 48

1.2.1 ZEIHE

RERRA T T BTG« 2P EMIZRERM AT LR ARRE, ST
HéS), BEERANERETIEMARE . 0 T HE, FASUETHHAR S E— 11T
WEFE o

GASRXS BIEX FLBGEGERITE, R R BRAI BB ARERE, By IyX BRI
BTEX AR —ME3 . yX BB WHRSER RS TR . SR AEIRELL T &,
RBRIZEE 5.2, BT TEHEAGN BIEX HF K-

)



6 CHAPTER 1. 4R

1.2.2 AEEEEM
o LyX EBRFFIERIFARRE -
T EAE, 1L the User’s Guide-o
o INTREX FRTFEAHARRE -
PO BEIX A - BABANEH BIRX 7E InX FREMEE T 4, FTLLEE the Embed-

ded Objects manual

AT IR TR A 5 — D SO RIB T -



Chapter 2
FiH Iy X

2.1 F—P IyX X

FHIEZ B LIE SN, X e ARERE L 155 RREH -

HTARBEASRMBERER, LURFERIE BRI . XREE: 5
) LyX, EWBSEEFHE the User’s Guide. 75 H ORISR Al LUEEEATT

(EMTAREGMEREFF) - FE, SITHZA R, AILLET View BB
PREEFEAT U -

BAVMBEREEHE T 2ThEEM LyX f1 BIEX, A% DVI. PDF SCHNEES . —#%
Fit, EAMEIERG L, 7B IyX WIRHEE C 2T T -

G, BAHEHT — DM example_raw.lyx, ARSI - BUEX DR
H— 12 AHE X FHEMASH), B rndiEd, RSB NRESEX30H:
1. example raw.lyx FHEE TBEHRIRERER . N T, FTNERET —10 LyX
mFEHRFRFERZER SR example lyxified.lyx -

IRNBISTRSFFAE T IyX ZEEBIZN examples HE N « FTFRFICE, BEHHCH
BT, BM/EHEE DVI UHFERR -

FEh, examples BRHMHREHERIARGISUE, EMTRFMERR IyX B8 AD)
AE o HIREIL T N IEEE 4 (A AR, Hr] LUERE B XS -

2.1.1 XA BE-. W
o fFFHSEEE File> New FT I -

o HIA—""A)F: This is my first IyX document!
o fHFZEE File>Save As fR1F AL

o JE1F BTEX AR DVI X0, (AR Views DVI 2t TERHEH B, 1yx #H7
7



8 CHAPTER 2. #JIH LyX

JF DVI-viewer 725 T/ SR TEIRS PR+ !
o fFFHZEHE Filer Export R 3RS H A A R RS = -

NE! RELFH THE - LyX 30H - Ry, ReEdeF s .

2.1.2 TEIEERE

LyX RES S| CBIFREMEI4 R 0, . BohifT . Bogdgaidt- - LUF
e JLAN R R E R T 1 -

W X BZREUETIEE, 7RI LA Edits Undo (BT EIZIRE ©) SEHUE AKX
Y 2GR LORRIBTE #0E « WAE0HE L 7, "I LU EditoRedo (B TR
AR &) RS .
HAETRTHBRESCRF10020, T ELBTH B AR RENS SCRFBITR Y, ELAnXS ST /)
R SO N BEBCRGE . X BBfE — 1 bug-

BIY) KNG /S (£ Edite Cut (T ERHE X) | Edite Copy (LR Q)
il Edit>Paste  (TEEH B) RSCDUBIY) . S HIFRIEERE . sl @
SPR A RORE G 8 SO (B H BRI ERISOR) -

B /B 55 EditeFind & Replace (T ERZHEL ) | 78 H LA IEHE A 5 o 7%
Fl “Find Next” TR, SETEHL © Replace” B RIFIFA - 2 /RiAA] LLTE
ERX K NFELFICE, YR DU R R .

FR#EE A Edite Text Style SF1EHEF A toggle buttons , ] LISRYE (BRIAEMAE) - hn
ez BN TESA (FhR—REDN, BT A% -

TE# AN T RERM 7 — L HE IR, FIan. RS $TE .
=98, HEnLIERA R Z KN LUERTR X LT EE AT H -

2.1.3 FrBIFTAE: IyX HHIEH

T PR, SMEERRRE LyX =AM TR . B REEARERE -1
17, MEREBAEERE PSR £28iTE, E—PZERETEGE . T Tab
WA EN— Tab f; SEPR LELCE Tab 4! AT LGB ERR AR E
Tab ALATAEE «

L$% DVIviewer7EfG GIB1T & T AR 1 . LUF AT LUS § Views Updates DVI 5t T E 2455060, 2%
LyX 2B EAUE VIHE] DVI-viewerRIA] o

MG RAE N, ARG ERIEH —EFET - LyX PRRER S D # AT LUXFE - T
BRI HRTAT .
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REZ FAFRER S AE WYSIWYG HA2 b, a2 FFMSEEEN (BT
BIAFTS) o LyX AR, EESAE WYSIWYM  (FrAERTArS) MH&z B REH 4
EIAT 4, LyX SOEARRPIRIR, SXEERIE T B SUHEREL . FIES B, S
Wrid, VEHEHAE TG LIRS - Tab ARSI EIEZER XL, Bl IyX ANHEF
Yo FH X, REERELZANEESECHANE, MASEIER . BLXT
WYSIWYM HIfiERES 0L Introduction -

IyX PR AE /DR SORE R TE - BR yX fTREAN S 100% K
i BRI B EHER o User’s Guide B8 T B FIEM T E, BFKTFER

(HFills) FIEEEE (B0 EEBEMRARTE) ; REFERD - 57
% WEERENFIRNFE . RATER LSRN, Ex/aME— T g
BIF T - FREERNTFOETA, REES SO TR s S HER T R L - 3

2.2 I

HBIANFERS S EANFERER, FATPXERRH “TE” (environments) - FR
SRR G (FiEE) Fafn. RESOHEESERIRNIAE, . 31a
HRMEMSE; BERXEMENSE, HeEHE.

R LyX P LRIET B 2 EERR sy - — PR TFERRRE L PR
FEC S Y80 - fTIRIBESESE - XA IEHEE, HA— 1M EENENREE L EREE
SRS ZS L o PN AT ESKIALRE AR~ 18pt~ JJH, TR — 1Al REE:
SKEMA « 15pt~ ZEXITE; ANFERNE S WE ARG ENE; 2% AR U 2 R
T o IyX SRR MG B A A R R

PRAT LAE T T B b (EREE T hiy S g Sonde Rk, B S IRIRE A
PIEREEAT 4, HA “Standard” & 3CARMIERAIAEE o BUETA PRFAE VR BT SR FR s in
ISR, REETCNRZEL TR,

2.2.1 77 (Section) 5F77 (Subsection)

7E IyX XS —1THI A “Introduction” , FEMIE FHKHEF KA “T”
(Section) *, WHEMRIERET “F7”  (Section) M AZE “T*”  (Section*) o LyX Kf7E
BOAM B 1 FREFEIAR . RS, AR “T7 (Section) Z2[E] “FRifE”
(Standard) - FAZEOAERLL, FEIF G IR L - B A SUR:

This is an introduction to my first LyX document.
BRI %, B8 F  (Section) ¥R8E, IyX #5 £ 2" HEMMA . BERA

“More Stuff” , LyX SERERT (Section) FRAAAIFEZ -
SEEIE: JE AbiWord iXFFREERFAIP ARG, BLAZUE MS Word » 000 ZUiL T, 1E&

Pif) “standard word processors” | JRFRHIAE T 4RI
NIRRT ESFET (B) |, YehnEEEARR . BRI ZITrME, MFEEEL -
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FEAREMEITT 1 (Section 1) KE, mEZE, HIEERN “T7”  (Section) , LyX
S5 <97 FFEREIA . BiA “About This Document” - WIZAHIT 2 (Section?2)
“More Stuff” , IFECEWEAL T 3 (Section 3) o IR ATHFEMEPLLFET
(Section) FR@l, InyX &AbFRGRS FHERUE AT, X2 BT WRIETAE. (WYSIWYM)
PR XA o

FEIEZE, [\ FRuE”  (Standard) ERBE, ®IANIA 5 7 NF:

Sections and subsections are described below.
Section Description

Sections are bigger than subsections.
Subsection description

Subsections are smaller than sections.

AR AT, FEWME RSB T (Subsection) o LyX R &7ERINAMN L
“2.17 , FIEFERPEERIHLIESCR, Y (Section) PR/ . HEEILER 4 FTHILEM
) “FH” (Subsection) , IyX REEERNAM E “2.27 « WERAET 2 (Section 2)
BRI BT R, 97 2 K& EHBZE RT3 (Section 3) , EIHF T HERELH
“3.17 M “3.2” .

B RREEF A FIRFT7 ( Subsubsection )~ Bt ( Paragraph ) F1F B¢ ( Subpara-
graph ), XLt ELE TR . BT ERAAEBIAEANRSH, HTFEIEE
Yk, 2 User’s Guide 5| Z R LI LMFTEZEEAN] . & (Chapter) & 3UHEEHR
st RE R —H%, AREERERER LyX R PARERE (K 3.1) -

RATREL AR E LT M T T EARSTH, LyX BRIHIELILX P IEE . 43T
THIFREIAMEIC “* (Section*) J5, LyX iR EEAMRIPIFER, H@EANEX
EHTRS - MNRBER B BT YRR ET S e iR
BT ER), FNEERENRSEABZEEE -

Z5>): MBEN example raw.lyx FHEITTFIF TIARE -

2.2.2 FFE (Lists) FIFF|FE (sublists)

LyX I JLRMIIRING, E5 RN By — 1 B R FIRE, 1XEF5RIA
B LR ARESUE R T E AR SRS

o ZNTHFAWE LA EIE (Itemize) -
o RINEH 95 HIMZENE (Enumerate) -
o ZIAFEREH FIRIAEE (Description) -

o JIRIMBE (List) FIFHARIASE (Description) ZAZL, HEXNTT T AFHHE AN -
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BERANE — 1 IyX ARMEARIFIER - SR

IyX is better than other word processors because:

IRIGRIIE %, FAEPSE MR R AR HIABE (temize) - IyX RETEIIL
B - 4REEN:

Typesetting is done for you.
Math is WYSIWYG

Lists are very easy to create!

FtRAAFE, FIRIAFEAEREEN AL, WyX SIWIIRREES T—15%H -

B LA B B AR ST E = ASN R . EHAFEVREILSE (Standard)  B5f8 B PR 4 S

Alt+P S A REIR I RINE - BAE—DHIRIPEH Z 4Bk, v A ORI % A
(Protected Break) , %~ Ctrl + [HZHI7A] .

REZBA T —NMERNFEINR, RENECEENKHFIEZEIT UTX R
EATHTETH R T2 ARG NN LR SR? R AREREBNIIRS, R
JEIREFEMEEIME  (Enumerate) BIA] o NSRRGSR HIE, nX 2 BB HRS
o

INAE ) 32 T34 72 Ab F 8k B RS, RAT DL #A  (Description) #1151 %

(List) PAFPEASE o XA FIERSRERE & IR0 E L RITE S, FRENE A B 24 1R FH AR
FIRINFE G FFE AR E LH “Tab” 5930 - BHAMZIEIMREZ T—MARE, F
BT LRI ZS 8 (Protected Blanks) 4147 -

2:>]: HEAR example_raw.lyx FHIFIF -

X LG RN A AT IR E A, RN & W E6+ - 95 5B A 195 R AE
FIRF2EHANFPRMER - HEZEES W User’s Guide -

2.2.3 HEE. . 5|HNEL

BHWFGI RS S—me5 HEATIHTE (Quote) s K—mMGI FHEHTISC
I8 (Quotation) o ITEMNLARGHEHALIEIAEE (LyX-Code) , ZIFE{E Htypewriter
TR, MHXEE WX FHE— R FFERZ DSB8 TT - (K8 7] DLEH IR

(Verse) RE#: EZEST, Ctrl + EZEWAT - NTEMEREEMAZ W User’s
Guide o
2:>): ABIN example_raw.lyx FHIGIH « fOIE « #FEASE -

SURFRANE RN — Bt —iEik EATE, IRRTEIRE LB — SR B RO KBS, R, IR T
EETIT - XRABULE, FOABEE TR CF L ERAFE, XL G5t 2 EZ -
OX B M TabZHER Tab (€2 BEMEIRKMOATFAKE) | MAREKKITFHLTab-
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Chapter 3

G e A

HIARIE TR T LyX REARBIEFIER A TE, ERE Wy X B T —1H)
BRI TR MR AR LyX &o8 T 530E/, . w3 - FHEifE. A
BRI G S B SUR, IRRF A EIDOEE L b FEITE - GBI 2R H
SRIEER T «

3.1 M3

R SRE R R 2, BB 8RR ATEN, R B ATEN . SRR
TR RS HOEREE . B (5 % (5 A HOAE RV 2 T B X BRI B A S o
BT - LyX #5020 B R R SOR R ORI BHERR 7 2t - A SR 68
RHBECRR . ORRRFT LI — D EEES, TE R IyX BRI, 5
AR B RS -

IRETSCRITTBE R CE (Article) SCRYH, MBI EHISORI% (8 Docu-
mento Settings MHERE) BEA 4 RA . PHEIBERR, 1ho % WEHSE FRAEH
RESETERRA, FDENATUMER “B" 55 (Chapter) T - WHERAEHE
ROZEFIRRCRSE  JRA] UB B BRI T RAE B AR T -

&R IR X B E BT AN BOWRE . TUBS T . Ba% i EIHLA
R, SR ES R TR, NERTMNE BT B CH (style files) |
P TR AT LU A TERHEBR AT SCEE T« TyX BEAT BT Article (AMS) SCRSZ S HF
B2 es. 8

XL ORI R, B2 E RS W Additional Features -

for IWNTEX users: this is equivalent to the I TEX document class
2That’s usually the default document class

SETE: AITEE P EIR L RESCRF WTEX ARSI, SCFF ISTEX MRS — D B E R FTIRFEGIT -
13



14 CHAPTER 3. YatE Y

Name Notes
ME (article) HE - TE
NE (article AMS) EERFEFETH
e (report) HECE K W
FFE (book) N L Fi e ) — 2L
ZJT A (presentation) 17 8H
F15 (letter) el . B ERIRINR

3.2 M. 5—HE

EEE, IRATFEERRE—UFH I Document > Settings ST IEHEH1% € 95 04K
BATT - BEXREEHFERELF AR - WE AL B3 B85, LyX B
PSR AT LI T A E], R A ZEE AR A A R 5 B S R AT

A File> New from Template, F£i5E4% letter.lyx Bt - LREFTED, BEEAN
[F] FRI AR R 1B A R -

TEE FHIFIRIER, (REFBILDBECERME R, W AL
(My Address) - BEIAEX ) LIEX BT — D — VR - IRATRES TR RIE 4R
(Signature) , &N FRIOEMELER) “Signature: ” FR%:, ZIREFH N HIRLEFTED
HORHIBES . ERESIFMRXEERXENES, EHINAEREBAEE, WX £
P ILRIATARRT, TR ERER R, IyX #ALEEFT RN E R IZ ST -

RS & — 1 LyX WS, IRAT VMBS — T A — 1R . TIREE
I, AR ST ERE - XERITAE RS, e EAGRHEE. 4

LT EHREREER T E KERE, FATEIZWEEHE - AINENILRESEH B
M2 EE A RSO - IR EIE LyX HBAAKe BRI H AE,
AR AEHR AT o« BHOLRERE R 22X LyX VR .

3.3 X HtRE

B E - 1EE - B 5. LyX RN SO B —ER 47

Wi — 1 LyX 0, SHEMEAEIRE (Artide) - SESE—1TEH L@ HH
LHNIREIE (Title) . F—175 LARIZFIH L NIEZERSE (Author) , BT
—17E EHBFH R B BIEAEE (Date) - RNEHE L—MBIHE, HF X NRENE

40ne warning, if you're writing from a template. If you erase all of the text in an environment — for
example, if you erase the whole My Address field so that you can replace it with your own — and then
you move the cursor without writing any text, the environment may disappear. This is because most
environments cannot exist without any text in them. Just reselect the environment from the Environment
box to get it back.

5You should not be using the letter any more, since the Letter document class doesn’t allow titles.



3.4. % (LABELS) 5% X5|H (CROSS-REFERENCES) 15

(Abstract) o BEIXLRPITEN HREZH 2T H . WERIESEROBEEER, Ke
B = BMEPRET], BEAEABRERE— T
Z5>): 1F example_raw.lyx TUEZNbRE - HE . 1EE -

3.4 ¥ (Labels) 53 X5|H (Cross-References)

PRAT LN E TR - FIRIT . A BTE - #ahik (floats) ISINIRE, ZJEWIHE
R E RS S X EI G e, TSI HET g5 Ha IS T, IyX 3
M= BITERXGI AN S - BEIPREMZ XEIHE yX M T2 e e
HIREL A -

3.4.1 ¥

FATEBIE N CHEPIE T, ERAEUE “About This Document” o R YEFRAE
FIZZATRE, 155 Insert>Label B TEFZHZH & FEXIEEF B AR S, i OK
&, PELRKS HIETE -

TIRER LURETHESEME, PRSI HARFSRNEREREN— 1 e FT1 -
PRAT DB AR TR b, BB RTINS —1T B, X RT DAGRIES | R DU &
TR T -

B HEI NI, BATEEMA 2FEE, WHE DVI B ASEMF A2, B
FRAS BT TR - BAECERMN T — 1%, NMARNPRFEETE X T
FR5IHE -

3.4.2 XXFH
W SERTE MBSO AT 2, B

If you want to know more about this document, then see

section, which can be found on page.

IR G B VR AR B 1R “section” f5 1M1, 1%EFE Insert Cross Reference B & 5 T B f=
WH @ HH AR NS HNIEE . RESEBERTHNRESER, SRIERE—
4~ “sec:About-This-Document”, % & T 3 &5 N H (Apply) #ZHl - L7E FH i
VrE ML BAE “page” J5il, FIEFIABKXE A TE, KEHBAHNAH. (8
TARUEHERR B IE R, DK FE BRI “section” 5| F Z B CE — N RIFE SR
(Protected Blank) - ¥ TURSHIS|FHH BixXHkE . )

FYMER LIETRE Ea S, £ R GER (CG#sER) Tk “Bdlhsg H”
(Copy as Reference) - iXFEHRFIFRZEAIZ X GIHBCAEEHIE] T BMEHRT, EFZEDN
b 75 RENGERAA] -
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IyX &R XGRS ET AL E - FEFTEN RSO, 5 RS H
TS (XEETIARKEEARENT) - ERHM DVI XS, & F
ZIXT7 2 (Section 2) FTL 1 (Page 1) BI5IH -

RER NG A HIZ X HMNIGE, SHE 2% (Go to Label) , YAnki&
ENEGHARE - X IREREA AR -

3.4.3 KTWRENELIL

Rl , yX 2 Bt EX X5 AR S, IERREX I £ 2 §iid
WIN—AN8r, BEE DVI Bt S0, SRR X G HEEZER 3 T - 8 “About
this Document” & &R T (subsection) , GIFKFSM 3 ZH 2.1 « HR, NERE
BRI —BTUCF R, 5 AT E A SRR -

ATV Z RN JL I nes, EHEMGTFIH—T - R EHT X5 HEREZ W
W, FFERXX B AEER TR -

AT LA User’s Guide AP, BlE CFd kS, 48— TH USR5 HAEA A EIE
fiff o

%>): BIE example_raw.lyx FEIFIH -

3.5 MIF (Footnotes) 5551 (Margin Notes)

S TEREH = 85k 8 Insert> Footnote, LB BEHEAME - 23X
RREEIE LyX” , ROt ENEEED, A TEEEE E, HEERSS HIE
“IyX” JEihl, AIDAZE B A, BERIA

IyX is a typesetting word processor.

ESCFRINE — 1 KE, BF “MFEx” (foot x) , XBEAY “x” ZHFERS, S
Y, BNERER S KH, R TANKAE, XPEENRA “r&”  (folding) , FRAES
N2 “BF>  (unfold) - LLETATLIRERS B © BRI SCF -

X—BEZIR, Bt AiE.

Rt AT DUG S B SCFAREE BT U] ~ RGNG, 2% 8 BENE K RE S5 B PT LUKEIG T - 7
Gh, R —BOUR B RS S, R DR — BOURER N IE T o Z2 IR
NHEMICT, AFER IR E M AEME &AL E Hi% TRME#  (Backspace) |
B RO E ML SCF I B e i T L TN ERE  (Delete) -

fH SR8 Insert > Marginal Note 5% T EA=#8 51, A LLRINSHE - S5 FIREIE A TH
fe LU ARME), HAFZOET:

o FE FERA “55F”  (margin) , BNFEERA “BE”  (foot) -

5By the way, copying a chapter title may cause an error, because chapters aren’t allowed in the article
class, see section 3.1. If this happens, just delete the chapter title.



3.6. Sk (BIBLIOGRAPHY) 17

o FHFENF R RAETUESS D, MHTE ST Eos7E DU EHT -
o FENRT -

R N EAT, BT REE - 217 WX EE ST AR .
25>]. EIE example_raw.lyx A HJHHIE -

3.6 Z%#HL (Bibliography)

% IR XGIHE AR, EAEGERRBE -5 HIE, IRA] R 5|
REN]. MEFIRE—FE, LyX il BIpXte S it B2 % EMN RS, SRS
A, BIHM S S -

SN ZE R B H VI 2 2% CHAEASE (Bibliography) . /REIARIEE— 1 BUE AT
R — DG AN R - WAEBASF — P 5/HIT:  “The Lyx Tutorial, by the IyX
Documentation Team” o LyX WF&TEREAGIHIIFHAMEMN F9wS, A&5]HITHL
IHES 2% WAL (Bibliography item) XIEHERL S HEL . H <8 (key) & IyX H
FRIFIZEI AR, FR%E (Label) K54 HEELAEH Hi 3O H o PREETIE B ERT (B
) | BSOS WIS E IR S o T IR, 18 BT (key) &
EH “lyxtutorial” o

AR AT AE O 28 SO EL 5 | FZ SCRk AR 7, 3%E%%F Insert > Citation B T B 2374
&, KIS FHXIERE (Citation dialog) o WTEHE A Z: T EIHRF] H T 0] A A SCHR T,
HEFE “lyxtutorial” FERERMIEEH (Add) faERFIHRSE (FEEZD) |, &E
R N HE ARG H (R D T — 2 8ME) - BEFHEHH, fa
BRI FESH LG S BRSNS T SR B2 STk -

G FHXERE R ERE T B2 72 77 185 51 TS 1 i — R, H RGBS
FAR) 2R — DB — &« B4R 5] F SCERBIPR ST A2 dm 5 HITE, £S5 SCERITUN 1R HE
(Bibliography item dialog) HXZEMAIEEIT] - BHEFEES W User’s Guide »

45>): {BIE example_raw.lyx HHIS 3 SCEAIUFIG| F -

3.7 H3X¥X (Table of Contents)

H LyX 7230 in B e % & 8. 72 SRR EUE AR, %5 Insertr
List / TOC»> Table of Contents HLAIHHAHK | - XI5 “Table of Contents” LPAfZH
FROFE 2 A SO ) 58— 1T

Wi EE, RERABERECEERT, BIIH T CEFRET IR - BHOUY
METE, EFmL 0N, BRIz Mz .

N T RSO AT IENE, LyX B9REE 0 PR AR R H R ANA - %5 Document >
Outline 2, T B2 @, BE—MFHAMIRNE O (Outline window) H E R HRN

TEIGRE AN
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7o MEIREE R EABR, X —BRIERRER . 3R EAE SR & HR 7y (8] PR IE
Ty, X—TESDH{HEIAEH . ERATOFAGHTE-ETIRE/FSm D RZ
1, HAEREE O P EMBIZET - IRIAT LUER T WA B R HHEN8 o G O
HFERNE IRSRITE . SHSRE (Navigate) tHREFRHERLITIAE -

fHiF Table of Contents & BEEEMI T H 3= T -

%5>]: EIE example_raw.lyx FHIH K .

SANMRTERL, JRFEAN «



Chapter 4

AORPERER BIEX, X RN ERBHE HER AN, SAHEREE T
B ER T EN R AN ERS - HXERERBE AP AR DIEX R,
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