如何切换内核?

为当前最终发行版之前的所有版本提供支持
回复
giligulu
帖子: 14
注册时间: 2018-01-19 16:03
系统: ubuntu16.04+win7
送出感谢: 2 次
接收感谢: 0

如何切换内核?

#1

帖子 giligulu » 2018-04-26 19:14

我的电脑是4.4.0版本的内核
请问有办法使用2.6.18版本的内核吗?
有的话要如何操作呢?
头像
astolia
论坛版主
帖子: 3019
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 495 次

Re: 如何切换内核?

#2

帖子 astolia » 2018-04-26 23:07

要2.6.18这么老的?
ubuntu没有用过2.6.18内核,所以没有已编译的deb包
debian倒是有, http://archive.debian.org/debian/pool/m ... _amd64.deb
大不了下载内核源代码自己编译总是可以的 https://mirrors.edge.kernel.org/pub/lin ... .18.tar.xz

由于内核功能缺失当前系统的libc库环境不一定能正常运作,当年的驱动也不见得能跑得起现在的硬件,最好去找个虚拟机安装2.6.18在2006年左右发布时的linux发行版,比如debian 4.0,它就是用的2.6.18内核
这些用户感谢了作者 astolia 于这个帖子:
giligulu (2018-04-27 14:21)
评价: 3.7%
giligulu
帖子: 14
注册时间: 2018-01-19 16:03
系统: ubuntu16.04+win7
送出感谢: 2 次
接收感谢: 0

Re: 如何切换内核?

#3

帖子 giligulu » 2018-04-27 14:20

嗯嗯,好的,谢谢。
回复

回到 “老旧版本支持”