昨天装了anbox,想装些应用试试,结果失败

为当前最终发行版之前的所有版本提供支持
回复
头像
scrutator
帖子: 49
注册时间: 2007-07-10 10:52
送出感谢: 0
接收感谢: 0

昨天装了anbox,想装些应用试试,结果失败

#1

帖子 scrutator » 2017-10-18 9:49

代码: 全选

~$ adb install A.apk
14158 KB/s (532622107 bytes in 36.735s)
Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]
这样...
头像
scrutator
帖子: 49
注册时间: 2007-07-10 10:52
送出感谢: 0
接收感谢: 0

Re: 昨天装了anbox,想装些应用试试,结果失败

#2

帖子 scrutator » 2017-10-18 9:52

是因为版本7.0吗?所以不能装?
头像
astolia
论坛版主
帖子: 3014
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 495 次

Re: 昨天装了anbox,想装些应用试试,结果失败

#3

帖子 astolia » 2017-10-18 12:03

INSTALL_FAILED_NO_MATCHING_ABIS这个错误是说,这个apk中包含了针对特定CPU架构编译的文件,但你当前使用的CPU不在其中,所以安装失败。
在x86模拟器中安装arm版的apk这种问题是很常见的。

以前用Genymotion的经验是需要额外安装一个兼容转换层
https://forum.xda-developers.com/showth ... ?t=2528952

anbox似乎对这个问题并不在意
https://github.com/anbox/anbox/issues/33
回复

回到 “老旧版本支持”