On Ubuntu16.04 and Mint 17.2: Run Kindle for PC with Wine

为当前最终发行版之前的所有版本提供支持
寺島聰子
帖子: 328
注册时间: 2016-06-03 14:39
系统: Mint 17.2 - MATE (64
送出感谢: 1 次
接收感谢: 1 次

Re: 没有Ubuntu 16.04有!

#16

帖子 寺島聰子 » 2017-09-28 22:50

1. No apt build-dep in Ubuntu 16.04 manpage
apt build-dep不存在?
[email protected]:~$ sudo apt-get build-dep -y wine
[sudo] password for jin:
Reading package lists... Done
Picking 'wine1.6' as source package instead of 'wine'
E: Unable to find a source package for wine
[email protected]:~$
poloshiao
论坛版主
帖子: 18220
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1946 次

Re: 没有Ubuntu 16.04有!

#17

帖子 poloshiao » 2017-09-29 9:08

apt build-dep不存在?
[email protected]:~$ sudo apt-get build-dep -y wine
Reading package lists... Done
Picking 'wine1.6' as source package instead of 'wine'
E: Unable to find a source package for wine
Check the deb-src lines first :
https://askubuntu.com/a/826891
寺島聰子
帖子: 328
注册时间: 2016-06-03 14:39
系统: Mint 17.2 - MATE (64
送出感谢: 1 次
接收感谢: 1 次

Re: 没有Ubuntu 16.04有!

#18

帖子 寺島聰子 » 2017-09-30 14:48

[email protected]:~$ ls /etc/apt/sources.list.d
ubuntu-ja.list wine-ubuntu-wine-builds-xenial.list
ubuntu-ja.list.save wine-ubuntu-wine-builds-xenial.list.save
[email protected]:~$
寺島聰子
帖子: 328
注册时间: 2016-06-03 14:39
系统: Mint 17.2 - MATE (64
送出感谢: 1 次
接收感谢: 1 次

Re: 没有Ubuntu 16.04有!

#19

帖子 寺島聰子 » 2017-09-30 15:08

I want to change
題号を「没有Ubuntu 16.04有!」から
「On Ubuntu 16.04 and Linux Mint 17.2: Run Kindle for PC with Wine」
寺島聰子
帖子: 328
注册时间: 2016-06-03 14:39
系统: Mint 17.2 - MATE (64
送出感谢: 1 次
接收感谢: 1 次

Re: 没有Ubuntu 16.04有!

#20

帖子 寺島聰子 » 2017-09-30 15:11

http://ubuntuhandbook.org/index.php/201 ... -04-16-10/
2. Then updates and install Wine 2.0 staging via commands:
sudo apt-get update
sudo apt-get install --install-recommends wine-staging
---------
以上までノーエラー。しかし次の行
To the above is no error. But the next line
To use Wine-Staging, simply add “/opt/wine-staging/bin/” in the fond of executable, for example:

/opt/wine-staging/bin/wine
/opt/wine-staging/bin/winecfg

For more, see the Wine-Staging usage.
何が書いてあるか、何をしたらいいのか、理解できません。
I can not understand what is written and what to do.
onlylove
论坛版主
帖子: 4436
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 100 次

Re: 没有Ubuntu 16.04有!

#21

帖子 onlylove » 2017-09-30 16:32

寺島聰子 写了:http://ubuntuhandbook.org/index.php/201 ... -04-16-10/
2. Then updates and install Wine 2.0 staging via commands:
sudo apt-get update
sudo apt-get install --install-recommends wine-staging
---------
以上までノーエラー。しかし次の行
To the above is no error. But the next line
To use Wine-Staging, simply add “/opt/wine-staging/bin/” in the fond of executable, for example:

/opt/wine-staging/bin/wine
/opt/wine-staging/bin/winecfg

For more, see the Wine-Staging usage.
何が書いてあるか、何をしたらいいのか、理解できません。
I can not understand what is written and what to do.
He install wine into /opt/winestaging, and /opt/t/wine-staging/bin is not in system's path, so need to type full path
if you did not install wine or have uninstalled it, you can use

代码: 全选

export PATH=$PATH:/opt/wine-staging/bin
add to environment variables
NOTE: the command works only for current shell, if you want add it permanently, add the command to the bottom of $HOME/.bashrc
寺島聰子
帖子: 328
注册时间: 2016-06-03 14:39
系统: Mint 17.2 - MATE (64
送出感谢: 1 次
接收感谢: 1 次

Re: On Ubuntu16.04 and Mint 17.2: Run Kindle for PC with Win

#22

帖子 寺島聰子 » 2017-10-01 3:32

第一
He install wine into /opt/winestaging, and /opt/t/wine-staging/bin is not in system's path, so need to type full path
if you did not install wine or have uninstalled it, you can use
代碼:
export PATH=$PATH:/opt/wine-staging/bin
add to environment variables
NOTE: the command works only for current shell, if you want add it permanently, add the command to the bottom of $HOME/.bashrc
彼はワインを/ opt / winestagingにインストールし、/ opt / t / wine-staging / binはシステムのパスにはないので、絶対パスを入力する必要があります
あなたがワインをインストールしていない、またはそれをアンインストールした場合は、
export PATH=$PATH:/opt/wine-staging/bin
環境変数に追加する
注:このコマンドは現在のシェルでのみ機能します。永続的に追加したい場合は、コマンドを$ HOME / .bashrcの最後に追加してください

第二
https://github.com/wine-compholio/wine- ... wiki/Usage
Multiple Wine versions
我粗解了第一、第二。
感謝
回复

回到 “老旧版本支持”