当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 98 篇帖子 ]  前往页数 上一页  1 ... 3, 4, 5, 6, 7
作者 内容
91 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-08-17 9:18 

注册: 2013-08-14 20:59
帖子: 5
系统: ubuntu+win7
送出感谢: 0 次
接收感谢: 0 次
wzhy90 写道:
wsj920602 写道:
wzhy90 写道:
wsj920602 写道:
wxjeacen 写道:
更新了安装方式。

请查看 1 楼我更新的地方。


我的怎么还是12.3的版本呢?apt-get update了也一样。
另外官方的tar.gz包下载之后怎么安装啊?没有./configure

官方的解压后直接运行emesene/emesene下面的emesene就行了
但是我这里运行后还是没有QQ,已经编译好libwebqq了,/usr/lib下面有libwebqq.so
郁闷,LS如果知道方法说一下


代码:
[email protected]:~$ cd libwebqq
[email protected]:~/libwebqq$ ./autogen.sh
+ aclocal
./autogen.sh: 3: ./autogen.sh: aclocal: not found


这是怎么回事啊

依赖包没装好,
sudo apt-get install pkg-config libtool libboost-dev python-dev libboost-python-dev



我安装了你给出的依赖包后,依然还是报这个错,怎么会事儿?


页首
 用户资料  
 
92 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-08-17 9:43 

注册: 2013-08-14 20:59
帖子: 5
系统: ubuntu+win7
送出感谢: 0 次
接收感谢: 0 次
goatok, 我也出现了这个问题,install automake, autoconf and libtool(老外网站给的)
sudo apt-get install pkg-config libtool libboost-dev python-dev libboost-python-dev
sudo apt-get install automake
sudo apt-get install autoconf


页首
 用户资料  
 
93 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-08-17 9:45 

注册: 2013-08-14 20:59
帖子: 5
系统: ubuntu+win7
送出感谢: 0 次
接收感谢: 0 次
ablmdream, 我也出现了这个问题,你的解决了吗?如果解决了请给予帮助,谢谢。


页首
 用户资料  
 
94 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-08-17 9:49 

注册: 2013-08-14 20:59
帖子: 5
系统: ubuntu+win7
送出感谢: 0 次
接收感谢: 0 次
ablmdream, 我的也出现了这个问题,使用这个语句解决:
sudo apt-get install libcurl4-openssl-dev


页首
 用户资料  
 
95 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-08-17 17:55 

注册: 2013-08-14 20:59
帖子: 5
系统: ubuntu+win7
送出感谢: 0 次
接收感谢: 0 次
wxjeacen, 执行最后一个命令 make && sudo make install的时候报错:
[email protected]:~/libwebqq$ make && sudo make install
(CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/lucky/libwebqq/build-aux/missing --run autoheader)
rm -f stamp-h1
touch config.h.in
cd . && /bin/bash ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
make all-recursive
make[1]: 正在进入目录 `/home/lucky/libwebqq'
Making all in jsoncpp
make[2]: 正在进入目录 `/home/lucky/libwebqq/jsoncpp'
Making all in src
make[3]: 正在进入目录 `/home/lucky/libwebqq/jsoncpp/src'
make[3]: 没有什么可以做的为 `all'。
make[3]:正在离开目录 `/home/lucky/libwebqq/jsoncpp/src'
make[3]: 正在进入目录 `/home/lucky/libwebqq/jsoncpp'
make[3]: 没有什么可以做的为 `all-am'。
make[3]:正在离开目录 `/home/lucky/libwebqq/jsoncpp'
make[2]:正在离开目录 `/home/lucky/libwebqq/jsoncpp'
Making all in src
make[2]: 正在进入目录 `/home/lucky/libwebqq/src'
make[2]: 没有什么可以做的为 `all'。
make[2]:正在离开目录 `/home/lucky/libwebqq/src'
Making all in wrappers
make[2]: 正在进入目录 `/home/lucky/libwebqq/wrappers'
Making all in boost
make[3]: 正在进入目录 `/home/lucky/libwebqq/wrappers/boost'
CXXLD libwebqqboost.la
/usr/bin/ld: cannot find -lboost_python-2.7
collect2: ld returned 1 exit status
make[3]: *** [libwebqqboost.la] 错误 1
make[3]:正在离开目录 `/home/lucky/libwebqq/wrappers/boost'
make[2]: *** [all-recursive] 错误 1
make[2]:正在离开目录 `/home/lucky/libwebqq/wrappers'
make[1]: *** [all-recursive] 错误 1
make[1]:正在离开目录 `/home/lucky/libwebqq'
make: *** [all] 错误 2

应该是缺少某个包导致的,但是我谷歌不出来该install哪个包,请帮忙,谢谢。


页首
 用户资料  
 
96 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-09-15 11:40 

注册: 2010-07-24 23:35
帖子: 122
送出感谢: 1
接收感谢: 0 次
#求助 同样的问题

$ make
make all-recursive
make[1]: Entering directory `/home/zjb/下载/libwebqq-master'
Making all in jsoncpp
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp'
Making all in src
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp/src'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp/src'
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp'
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp'
Making all in src
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/src'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/src'
Making all in wrappers
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/wrappers'
Making all in boost
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/wrappers/boost'
CXXLD libwebqqboost.la
/usr/bin/ld: cannot find -lboost_python-2.7
collect2: error: ld returned 1 exit status
make[3]: *** [libwebqqboost.la] Error 1
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/wrappers/boost'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/wrappers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/zjb/下载/libwebqq-master'
make: *** [all] Error 2


页首
 用户资料  
 
97 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-09-15 15:42 

注册: 2010-07-24 23:35
帖子: 122
送出感谢: 1
接收感谢: 0 次
nodig 写道:
#求助 同样的问题

$ make
make all-recursive
make[1]: Entering directory `/home/zjb/下载/libwebqq-master'
Making all in jsoncpp
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp'
Making all in src
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp/src'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp/src'
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/jsoncpp'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp'
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/jsoncpp'
Making all in src
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/src'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/src'
Making all in wrappers
make[2]: Entering directory `/home/zjb/下载/libwebqq-master/wrappers'
Making all in boost
make[3]: Entering directory `/home/zjb/下载/libwebqq-master/wrappers/boost'
CXXLD libwebqqboost.la
/usr/bin/ld: cannot find -lboost_python-2.7
collect2: error: ld returned 1 exit status
make[3]: *** [libwebqqboost.la] Error 1
make[3]: Leaving directory `/home/zjb/下载/libwebqq-master/wrappers/boost'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/zjb/下载/libwebqq-master/wrappers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/zjb/下载/libwebqq-master'
make: *** [all] Error 2


这个问题在这个帖子找到了解决办法:http://forum.ubuntu.org.cn/viewtopic.php?t=395250&p=2898057

但是编译完成后,在emesene里没有找到webqq协议。


页首
 用户资料  
 
98 楼 
 文章标题 : Re: 推荐 linux 下 emesene 的新版 qq client 支持32位和64位
帖子发表于 : 2013-09-28 17:57 
头像

注册: 2007-09-11 21:51
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
[FAIL] Can not get ptwebqq from Cookies ... (QQPlugin.cpp,105)


不能登录啊

我能登录webqq网络木有问题 :em20 :em20 :em20


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 98 篇帖子 ]  前往页数 上一页  1 ... 3, 4, 5, 6, 7

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译