Emacs23 配置指南

Vim、Emacs配置和使用
回复
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#76

帖子 zhan » 2006-11-29 18:52

To erlv:

代码: 全选

(defun linux-cpp-mode ()
      "my cpp mode define"
      (interactive)
      (c-set-style "K&R")
      (setq c-basic-offset 8)
      (define-key c++-mode-map [return] 'newline-and-indent)
      )

   (defun linux-c-mode ()
      "my c mode define"
      (interactive)
      (c-set-style "K&R")
      (setq c-basic-offset 8)
      (define-key c-mode-map [return] 'newline-and-indent)
    )

   (add-hook 'c++-mode-hook 'linux-cpp-mode)
   
   (add-hook 'c-mode-hook 'linux-c-mode)
   
回车就能够自动缩排
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
forcotton
帖子: 57
注册时间: 2006-10-06 21:10
送出感谢: 0
接收感谢: 0

楼上

#77

帖子 forcotton » 2006-12-21 7:05

楼上:
有个hook叫 c-mode-common-hook 只要在上面加就好了。
(add-hook 'c-mode-common-hook 'my-c-mode-common-hook)
smartcar
帖子: 131
注册时间: 2006-04-07 14:14
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

真详细,收藏了

#78

帖子 smartcar » 2006-12-28 11:30

我觉得最重要的是emacs23能够直接接受输入法工具了,以前用内置的中文输入,限制了很多应用。
field
帖子: 156
注册时间: 2005-05-31 19:32
送出感谢: 0
接收感谢: 0

#79

帖子 field » 2006-12-28 16:46

请问78楼主
Emacs23下怎么设置能够接受输入法工具? 用的是什么输入法?
flashzs
帖子: 36
注册时间: 2006-06-03 22:28
送出感谢: 0
接收感谢: 0
联系:

Re: Emacs23 配置指南

#80

帖子 flashzs » 2007-01-08 14:13

zhan 写了:声明: 本人在配置 emacs23 过程中参考了网上众多网友的帖子。因此,很多部分都不是原创,在此就当作一个emacs23解决方案收集帖把!^_^

首先有一个问题要说说,就是在 gnome环境下,使用utf8的local的时候,emacs无法调出scim/fcitx输入法,虽然emacs自带输入法,但是很不好用。据说这个问题是gnome的问题。因为我不用gnome,所以也没有什么解决办法.
1.下载源代码
可以用最新的 cvs版的,这样需要从 cvs上下代码了,此时需要做一些准备工作

代码: 全选

sudo apt-get install ssh cvs(这个是为了在 cvs上下载代码用的)
sudo apt-get install texinfo(这个是为了方便后面的编译man包)
然后到 cvs服务器上下载最新的代码,先进入自己家目录

代码: 全选

 export CVS_RSH="ssh"
 cvs -z3 -d:pserver:[email protected]:/cvsroot/emacs co -r emacs-unicode-2 emacs
然后就等待把,一段时间后 cvs会结束,此时会在你的家目录下面建立一个emacs的目录,这个目录下面就是 emacs 的 cvs代码,整个大概需要 80M左右的文件,而且如果速度不是很好的话,会很烦的。
对于心急的朋友,还有一个办法,我几个月前 cvs了一个源码,打包后放到 共享 ftp上了,可以到那里下载。
在目录 "software/文本工具" 下面。

代码: 全选

 wget http://ftp.ubuntu.org.cn/software/文本工具/emacs23.tar.bz2
2.编译
先配置一些编译环境把,具体的我记不太请了

代码: 全选

sudo apt-gt install build-essential
sudo apt-get build-dep emacs21
sudo apt-get install xserver-xorg-dev
sudo apt-get install xorg-dev
sudo apt-get install libncurses5 
sudo apt-get install libncurses5-dev
(感谢关注本帖的朋友们提供)
如果是 cvs的包,那么直接进入 家目录下面的emacs目录,如果是从共享 ftp上 wget 来的,需要先解压

代码: 全选

tar jxvf emacs23.tar.bz2
同样会生成一个emacs 的目录,然后用下面的方法编译

代码: 全选

 ./configure --prefix=/usr --with-x-toolkit=gtk
如果这一步报错,很可能是因为没有安装 gtk2的开发包,那就安装吧。( sudo apt-get install libgtk2.0-dev)
同时根据报错的提示来安装其他的dev包。
make bootstrap
make info
sudo make install
如果提示缺少什么包,那么就安装下相应的包把。
编译的过程中出现了一些警告,我是没有理会他,呵呵,只要不出现 error,问题就不大。
要是实在不想浪费时间编译也可以直接下载我上传的emacs23的包,直接解压后进入目录 sudo make install 就好了。郁闷,不会打deb包。
昨天刚刚打了一个 deb包,测试了一下,还可以的说。需要的朋友们可以直接下载

代码: 全选

wget http://ftp.ubuntu.org.cn/software/文本工具/emacs_23-1_i386.deb
[/color]
3.初步配置
如果上面的编译安装没有任何问题的话,恭喜你,安装成功了。可以运行一下看看效果!当时的图片已经不在了,就不截图了~
此时是没有 .emacs 文件的。这个文件是 emacs 的初始化配置文件此时就建立一个把。
先来一些基本的配置吧。首先是中文字体,ubuntu下默认的 emacs 的字体太让人不爽了,我们可以在 .Xresources中设定。
将下面的代码放到你的 ~/.Xresources中,没有这个文件的话就新建一个。

代码: 全选

 Emacs.Font:fontset-chinese
   Emacs.Fontset-0:-*-fixed-medium-r-*-*-14-*-*-*-c-*-fontset-chinese,\ 
   chinese-gb2312:-*-wenquanyi bitmap song-*-*-normal--*-*-*-*-*-*-iso10646-1,\
   chinese-big5-1:-*-wenquanyi bitmap song-*-*-normal--*-*-*-*-*-*-iso10646-1,\
   chinese-big5-2:-*-wenquanyi bitmap song-*-*-normal--*-*-*-*-*-*-iso10646-1
说明:我这里用的是文泉驿字体显示中文,用 fixed字体显示英文,这样就可以正常的显示绝大多数的字体了。但是有些繁体还是不正常,比较郁闷的说。另外,如果不想用 wqy 字体,也可以用其他的字体,比如ar pl new sung等等的,只要在 xlsfonts的列表中能够看到,就可以在这里的冒号后面使用,如果对其他的编码有要求的话,也可以指定字体。在emacs 的 Options->mule->describe language enviroment中可以看到对各个环境以的描述。要设置的话,很简单:把相应的环境放到冒号前面,把字体放到冒号后面就好。
写好后用 xrdb -load ~/.Xresources 然后再启动,看看,字体是不是漂亮多了~
然后可以设置一些其他的东西,需要的话,把下面的代码加入到 ~/.emacs中把(没有就新建)

代码: 全选

(setq default-major-mode 'text-mode);一打开就起用 text 模式。
(global-font-lock-mode t);语法高亮
(auto-image-file-mode t);打开图片显示功能
(fset 'yes-or-no-p 'y-or-n-p);以 y/n代表 yes/no,可能你觉得不需要,呵呵。
(column-number-mode t);显示列号
(show-paren-mode t);显示括号匹配
(display-time-mode 1);显示时间,格式如下
(setq display-time-24hr-format t)
(setq display-time-day-and-date t)
(tool-bar-mode nil);去掉那个大大的工具栏
(scroll-bar-mode nil);去掉滚动条,因为可以使用鼠标滚轮了 ^_^
(mouse-avoidance-mode 'animate);光标靠近鼠标指针时,让鼠标指针自动让开,别挡住视线。很好玩阿,这个功能
(setq mouse-yank-at-point t);支持中键粘贴
(transient-mark-mode t);这个忘了,郁闷!
(setq x-select-enable-clipboard t);支持emacs和外部程序的粘贴
(setq frame-title-format "[email protected]%b");在标题栏提示你目前在什么位置。你要把zhan改成自己的用户名
(setq default-fill-column 80);默认显示 80列就换行
等等等等,还有非常多的配置,就不在这里贴出来了。网上也有很多,都有详细的解释的。各位朋友们可以自己去查找。

…… ……
我在Ubuntu edgy 下面是可以调用SCIM的,但是一切换到 xg/Beryl 下面SCIM就不能被Emscs调用了。

安装是基本按照你的方法来的。

P:你的ftp链接都不能用了……改改吧,呵呵

最后,谢谢

:)
附件
emacs测试_withoutxgl.png
winsphinx
帖子: 65
注册时间: 2006-06-07 13:25
送出感谢: 0
接收感谢: 0

#81

帖子 winsphinx » 2007-01-11 19:49

那个ftp的用户密码是什么?无法登录
shengqb
帖子: 9
注册时间: 2006-12-29 14:03
送出感谢: 0
接收感谢: 0

#82

帖子 shengqb » 2007-01-11 21:59

收藏
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

Re: Emacs23 配置指南

#83

帖子 zhan » 2007-01-12 14:12

flashzs 写了:
我在Ubuntu edgy 下面是可以调用SCIM的,但是一切换到 xg/Beryl 下面SCIM就不能被Emscs调用了。

安装是基本按照你的方法来的。

P:你的ftp链接都不能用了……改改吧,呵呵

最后,谢谢

:)
很久没有注意这个帖子了,谢谢兄弟指出问题,稍作了一点修改,关于 ftp 的问题也作了说明,还有输入法和 xft 字体的问题。还有要说的是我的 kde 在 beryl 下面输入是没有问题的。你试试开启 xft 支持看看能不能解决这个问题。具体可以查找 karron 的帖子,我在文章中给出了链接。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
distar
帖子: 140
注册时间: 2006-08-06 16:33
来自: [email protected]
送出感谢: 0
接收感谢: 0
联系:

#84

帖子 distar » 2007-02-02 13:39

刚刚试了下,无法登录~
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#85

帖子 zhan » 2007-02-03 16:20

什么无法登录?
如果是 ftp 的问题,请认真看顶楼帖子,有关于 ftp 的说明的。还给出了那个包含用户名和密码的帖子的链接.
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
jk88811
帖子: 55
注册时间: 2006-02-16 9:42
送出感谢: 0
接收感谢: 0
联系:

#86

帖子 jk88811 » 2007-03-14 12:37

:cry:
CVS连接不上了...

在网上找了另外一个CVS连接,貌似也不行!连安装都这么难,很多设置又不知所谓,Emacs23最狠,难产到现在还没起色。到底要叫我们等到什么时候啊!

看来Emacs真的是“神的编辑器”,我还是去用“编辑器的神”好了 :evil:
BeginneR
帖子: 6
注册时间: 2005-10-26 21:41
送出感谢: 0
接收感谢: 0

#87

帖子 BeginneR » 2007-03-19 10:37

安装lz的方法,编译安装成功
十分感谢

有几个小问题,请dx帮忙看看
1. 升到23后,注释中的文字没有加亮了,但是像/*和*/这两个还是有颜色的,即
/*注释*/ 里面,注释这俩字是白的,两端的符号是红的
请问怎么设置成以前版本的样子 注释中文字也加亮 3x

2. zhcon下按[email protected]时,zhcon的输入法会蹦出来,我打算把set-mark-command的键绑定改掉
但是想了几个都不是很舒服 希望有经验的推荐个舒服的 谢了
小刚paul
帖子: 7
注册时间: 2007-03-01 10:37
送出感谢: 0
接收感谢: 0

按楼主的方法编译了,安装了......

#88

帖子 小刚paul » 2007-03-23 1:52

一切OK,输入法和插件都很好,中文OK。就是Emacs的菜单的字显得N的大,丑就一个字,google了一大堆东西,直接设菜单的字体也不成功,不知道原因何在。但是换成用楼主的deb包安装,一切OK,就是中文输不进。折腾了大半夜,用Gvim去了,虽然Emacs人称“神的编辑器”,但是安装和配置如此麻烦的东西,我还是要说一句,这是一个垃圾,就算你们用板砖拍死我,我还是要说,连安装都很麻烦的东西,只有一语以概之,此为垃圾!!!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#89

帖子 zhan » 2007-03-23 12:10

安装麻烦是因为这个还是 alpha 版本,通俗一点说就是 内部测试版本,配置的话,其实不怎么配置也是可以使用的,只是这些插件都是为了各种不同的需求才需要的。如果没有这方面的需求,大可不必安装这么多的插件..

至于 deb 包,当时我打包的时候还不支持 xft, 因此中文在 gnome 上是无法输入的,这一点在主帖上已经解释过。菜单字体是受 gtkrc 控制的,只要有相应的配置,应该没有问题.

后来我在 edgy 中还打过一个包,可以支持 xft 的,可以看看 viewtopic.php?t=40210

至于楼上兄弟,大可不必如此激动,本来编辑器就是一个各有所好的东西,要用什么不用什么没有定论,只是多一个选择罢了..
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
小刚paul
帖子: 7
注册时间: 2007-03-01 10:37
送出感谢: 0
接收感谢: 0

#90

帖子 小刚paul » 2007-03-23 16:56

在Dapper下边双击下载的这个包,提示 Error: Dependency is not satisfiable: libatk1.0-0
在新立得里,看到libatk1.0-0 好象是装了的,不知道啥原因
回复

回到 “Vim和Emacs”