求助!启动VMware出错,运行VMware之前需要编译一些模块并加载到内核中

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
[email protected]
帖子: 4
注册时间: 2017-05-25 7:45
系统: Ubuntu16
送出感谢: 0
接收感谢: 0

求助!启动VMware出错,运行VMware之前需要编译一些模块并加载到内核中

#1

帖子 [email protected] » 2018-01-21 22:05

我系统是Ubuntu16.04,然后虚拟机的版本我也不知道怎么看 :Cry ,因为我们公司的开发环境装在虚拟机里的,所以很重要.但是今天发现一点VMware就弹出一个对话框说:
before you can run VMware,several modules must be compiled and loaded into the running kernel.下面是cancel 和 install 的按钮,
然后我点击install
就又弹出一个窗口标题是VMware Kernel Module Updater,显示
Stopping VMware Services
Compiling:
->Virtual Network Device
Runnig depmod
Starting VMware Services

Cancel

编着编着就弹出一个error窗口说

Unable to start services
See log file /tmp/vmware-root/vnware-7692.log for details.
OK

点击OK之后就又弹出上面的第一个窗口 before you can run VMware,several.......
这是怎么回事啊?网上查了下说是系统更新引起问题?
怎么解决啊?
那个logfile文件的内容如下:

2018-01-21T22:03:35.176+08:00| vthread-4| I125: Log for VMware Workstation pid=8536 version=12.5.7 build=build-5813279 option=Release
2018-01-21T22:03:35.176+08:00| vthread-4| I125: The process is 64-bit.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
2018-01-21T22:03:35.176+08:00| vthread-4| I125: Host is Linux 4.13.0-26-generic Ubuntu 16.04.2 LTS
2018-01-21T22:03:35.175+08:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2018-01-21T22:03:35.175+08:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/config": No such file or directory.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/preferences": No such file or directory.
2018-01-21T22:03:35.176+08:00| vthread-4| I125: PREF Failed to load user preferences.
2018-01-21T22:03:35.235+08:00| vthread-4| W115: Logging to /tmp/vmware-root/vmware-8536.log
2018-01-21T22:03:35.244+08:00| vthread-4| I125: Obtaining info using the running kernel.
2018-01-21T22:03:35.244+08:00| vthread-4| I125: Created new pathsHash.
2018-01-21T22:03:35.244+08:00| vthread-4| I125: Setting header path for 4.13.0-26-generic to "/lib/modules/4.13.0-26-generic/build/include".
2018-01-21T22:03:35.244+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.244+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.244+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.244+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.251+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.252+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.396+08:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-26-generic/build/Module.symvers
2018-01-21T22:03:35.396+08:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-26-generic/build/Module.symvers.
2018-01-21T22:03:35.419+08:00| vthread-4| I125: Read 22181 symbol versions
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Reading in info for the vmmon module.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Reading in info for the vmnet module.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Reading in info for the vmblock module.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Reading in info for the vmci module.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Reading in info for the vsock module.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Setting vsock to depend on vmci.
2018-01-21T22:03:35.420+08:00| vthread-4| I125: Invoking modinfo on "vmmon".
2018-01-21T22:03:35.422+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2018-01-21T22:03:35.422+08:00| vthread-4| I125: Invoking modinfo on "vmnet".
2018-01-21T22:03:35.424+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-01-21T22:03:35.424+08:00| vthread-4| I125: Invoking modinfo on "vmblock".
2018-01-21T22:03:35.426+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-01-21T22:03:35.426+08:00| vthread-4| I125: Invoking modinfo on "vmci".
2018-01-21T22:03:35.428+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-01-21T22:03:35.428+08:00| vthread-4| I125: Invoking modinfo on "vsock".
2018-01-21T22:03:35.430+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2018-01-21T22:03:35.447+08:00| vthread-4| I125: to be installed: vmnet status: 0
2018-01-21T22:03:35.471+08:00| vthread-4| I125: Obtaining info using the running kernel.
2018-01-21T22:03:35.471+08:00| vthread-4| I125: Setting header path for 4.13.0-26-generic to "/lib/modules/4.13.0-26-generic/build/include".
2018-01-21T22:03:35.471+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.471+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.471+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.471+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.478+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.478+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.622+08:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-26-generic/build/Module.symvers
2018-01-21T22:03:35.622+08:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-26-generic/build/Module.symvers.
2018-01-21T22:03:35.644+08:00| vthread-4| I125: Read 22181 symbol versions
2018-01-21T22:03:35.644+08:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.13.0-26-generic/build/include
2018-01-21T22:03:35.644+08:00| vthread-4| I125: Update kernel header path to /lib/modules/4.13.0-26-generic/build/include
2018-01-21T22:03:35.644+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.644+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.644+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.644+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.651+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.651+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.652+08:00| vthread-4| I125: Found compiler at "/usr/bin/gcc"
2018-01-21T22:03:35.656+08:00| vthread-4| I125: Got gcc version "5.4.0".
2018-01-21T22:03:35.656+08:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-01-21T22:03:35.656+08:00| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc".
2018-01-21T22:03:35.659+08:00| vthread-4| I125: Got gcc version "5.4.0".
2018-01-21T22:03:35.659+08:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-01-21T22:03:35.661+08:00| vthread-4| I125: Trying to find a suitable PBM set for kernel "4.13.0-26-generic".
2018-01-21T22:03:35.661+08:00| vthread-4| I125: No matching PBM set was found for kernel "4.13.0-26-generic".
2018-01-21T22:03:35.661+08:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-01-21T22:03:35.661+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.662+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.662+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.662+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.670+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.670+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.672+08:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-01-21T22:03:35.672+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.672+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.672+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.672+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.680+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.680+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.681+08:00| vthread-4| I125: Using temp dir "/tmp".
2018-01-21T22:03:35.682+08:00| vthread-4| I125: Obtaining info using the running kernel.
2018-01-21T22:03:35.682+08:00| vthread-4| I125: Setting header path for 4.13.0-26-generic to "/lib/modules/4.13.0-26-generic/build/include".
2018-01-21T22:03:35.682+08:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-26-generic/build/include" for kernel release "4.13.0-26-generic".
2018-01-21T22:03:35.682+08:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-26-generic/build/include/linux/version.h
2018-01-21T22:03:35.682+08:00| vthread-4| I125: /lib/modules/4.13.0-26-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-01-21T22:03:35.682+08:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-01-21T22:03:35.693+08:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-26-generic".
2018-01-21T22:03:35.693+08:00| vthread-4| I125: The header path "/lib/modules/4.13.0-26-generic/build/include" for the kernel "4.13.0-26-generic" is valid. Whoohoo!
2018-01-21T22:03:35.845+08:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-26-generic/build/Module.symvers
2018-01-21T22:03:35.845+08:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-26-generic/build/Module.symvers.
2018-01-21T22:03:35.869+08:00| vthread-4| I125: Read 22181 symbol versions
2018-01-21T22:03:35.869+08:00| vthread-4| I125: Invoking modinfo on "vmnet".
2018-01-21T22:03:35.872+08:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-01-21T22:03:36.364+08:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.13.0-26-generic/misc/vmnet.ko".
2018-01-21T22:03:36.364+08:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2018-01-21T22:03:36.373+08:00| vthread-4| I125: Successfully extracted the vmnet source.
2018-01-21T22:03:36.373+08:00| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-BU2U7s/vmnet-only auto-build HEADER_DIR=/lib/modules/4.13.0-26-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2018-01-21T22:03:39.590+08:00| vthread-4| W115: Failed to build vmnet. Failed to execute the build command.

请问怎么解决这个问题啊? :Cry
[email protected]
帖子: 4
注册时间: 2017-05-25 7:45
系统: Ubuntu16
送出感谢: 0
接收感谢: 0

Re: 求助!启动VMware出错,运行VMware之前需要编译一些模块并加载到内核中

#2

帖子 [email protected] » 2018-01-23 18:33

楼主我直接卸了VMware12.0,装了一个VMware14.0就能打开了.大家不要学我这种不求甚解的做法 :em02
回复

回到 “虚拟机和虚拟化”