无法定位软件包 python-PyGreSQL

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
kerrysu
帖子: 25
注册时间: 2016-03-29 9:56
系统: ubuntu
送出感谢: 11 次
接收感谢: 0

无法定位软件包 python-PyGreSQL

#1

帖子 kerrysu » 2016-06-28 17:41

安装python-PyGreSQL时候出现:无法定位软件包 python-PyGreSQL,更新和换源还是无法解决,求大神指点,感谢,用的是Ubuntu Kylin16.04版本。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 无法定位软件包 python-PyGreSQL

#2

帖子 vickycq » 2016-06-28 18:38

kerrysu 写了:无法定位软件包 python-PyGreSQL[/size]
1. 确保正确开启软件源的 universe 区
检查 /etc/apt/sources.list 看是否有 universe 字样

2. 注意 软件包名称全部为小写字母

代码: 全选

sudo apt install python-pygresql
参考 http://packages.ubuntu.com/xenial/python-pygresql
这些用户感谢了作者 vickycq 于这个帖子:
kerrysu (2016-06-28 18:43)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
poloshiao
论坛版主
帖子: 18000
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1914 次

Re: 无法定位软件包 python-PyGreSQL

#3

帖子 poloshiao » 2016-06-28 20:58

養成好習慣
安裝或更新任何套件以前
先執行
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade # 選項 新手不建議
然後再開始安裝或更新任何套件
这些用户感谢了作者 poloshiao 于这个帖子:
kerrysu (2016-06-28 20:59)
评价: 3.7%
回复

回到 “数据库管理”