当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Mysql配置字符集失败,求助大神。问题已解决。
帖子发表于 : 2016-04-24 1:17 

注册: 2015-09-21 13:59
帖子: 43
系统: Ubuntu
送出感谢: 6
接收感谢: 0 次
目前使用是Ubutu16.04LTS系统,Mysql Ver 14.14 Distrib 5.7.11, for Linux (x86_64) ;网上的教程基本试过了,但是没用。
主要试过以下2种方法:
第一种是 sudo vi /var/lib/mysql/mysql/db.opt 并且修改为

default-character-set=utf8
default-collation=utf8_swedish_ci

第二种是 修改 /etc/mysql/my.cnf 不过这个配置文件里面是空的,于是找了找,在debain.cnf下面找到了
# Automatically generated for Debian scripts. DO NOT TOUCH!
[client]
host = localhost
user = debian-sys-maint
password = ZuE3yWXT1tLzcB0k
socket = /var/run/mysqld/mysqld.sock
default-character-set=utf8

[mysql_upgrade]
host = localhost
user = debian-sys-maint
password = ZuE3yWXT1tLzcB0k
socket = /var/run/mysqld/mysqld.sock
character_set_server=utf8
init_connect='SET NAMES utf8'
于是我自己琢磨着分别在[client]加了default-character-set=utf8,在[mysql_upgrade]下加了character_set_server=utf8
init_connect='SET NAMES utf8'
结果当然是没用的。求助大神帮忙。


最后由 日升月恒 编辑于 2016-04-24 9:52,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Mysql配置字符集失败,求助大神
帖子发表于 : 2016-04-24 9:51 

注册: 2015-09-21 13:59
帖子: 43
系统: Ubuntu
送出感谢: 6
接收感谢: 0 次
问题已解决,附上解决方法。另外说一句,5.7跟之前几个版本的配置文件不太一样,对于我这种照本宣科的配置小白来说,难度着实不小。好在最终蒙对了。

打开/etc/mysql 文件夹,找到debain.cnf文件

备份debain.cnf

cp debain.cnf debain.cnf备份.cnf

vi debain.cnf

[client]下添加: default-character-set=utf8

并将以下内容复制到 /etc/mysql/my.cnf

[client]

default-character-set=utf8



sudo vi /usr/share/mysql/my-default.cnf

将以下内容复制到 /etc/mysql/my.cnf下

[mysqld]

character_set_server = utf8

init_connect='SET NAMES utf8'

#以上下划线部分为我自行添加的

 # Remove leading # and set to the amount of RAM for the most important data

# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

# innodb_buffer_pool_size = 128M

# Remove leading # to turn on a very important data integrity option: logging

# changes to the binary log between backups.

# log_bin

# These are commonly set, remove the # and set as required.

# basedir = .....

# datadir = .....

# port = .....

# server_id = .....

保存退出,并重启。

serviec mysql start


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Mysql配置字符集失败,求助大神。问题已解决。
帖子发表于 : 2017-06-23 16:17 
头像

注册: 2008-07-28 19:29
帖子: 249
送出感谢: 0 次
接收感谢: 0 次
找了好久,网上说的改my.cnf里面加两行后直接mysql打不开了,等会儿试试你的这方法


_________________
神舟天运F5600
酷睿T5750
GMA X3100
1G DDR2

http://new.qzone.qq.com/422253866/


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Mysql配置字符集失败,求助大神。问题已解决。
帖子发表于 : 2017-06-23 21:42 
头像

注册: 2008-07-28 19:29
帖子: 249
送出感谢: 0 次
接收感谢: 0 次
刚测试了成了, 用show variables like '%char%' ;
看到都变成utf8了,
只是楼主这东西写的英语字母打错的太多,如果一点都不懂的人看反而怎么也搞不定了 ,呵呵


_________________
神舟天运F5600
酷睿T5750
GMA X3100
1G DDR2

http://new.qzone.qq.com/422253866/


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Mysql配置字符集失败,求助大神。问题已解决。
帖子发表于 : 2017-06-26 17:22 

注册: 2015-09-21 13:59
帖子: 43
系统: Ubuntu
送出感谢: 6
接收感谢: 0 次
staunch 写道:
刚测试了成了, 用show variables like '%char%' ;
看到都变成utf8了,
只是楼主这东西写的英语字母打错的太多,如果一点都不懂的人看反而怎么也搞不定了 ,呵呵


时间太久,不记得了。来个感谢 :em09 ,然后献上你的解决方案 :em03


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译