是否可以恢復所有更新?

Bionic Beaver
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

是否可以恢復所有更新?

#1

帖子 寺島聰子 » 2018-11-07 0:11

Peppermint9で、元来アップデートマネージャーでレベル表示を3までに指定してた。
しかし以下のシェルスクリプトを実行したら、気がつくと、
すべてがアップデートされた。以下のスクリプトの どの部分が 自分の要望と合致しないのか?
またこれらの変更を いったんすべて元へ戻すことは できますか?
在Peppermint 9中,我最初使用更新管理器將級別顯示指定為3。
但是,如果執行以下shell腳本,
一切都更新了。 以下腳本的哪一部分與我的請求不符?
我可以將所有這些更改恢復原狀嗎?


#!/bin/bash
#
sudo echo "sudo apt-get -y autoremove"
sudo apt-get -y autoremove
#
sudo echo "sudo apt-get -y autoclean"
sudo apt-get -y autoclean
#
sudo echo "sudo apt-get -y clean"
sudo apt-get -y clean
#
sudo echo "sudo apt-get -y check"
sudo apt-get -y check
#
# sudo echo "sudo apt-get -f -y install"
# sudo apt-get -f -y install
#
sudo echo "sudo dpkg --configure -a"
sudo dpkg --configure -a
#
sudo echo "sudo apt-get -y update"
sudo apt-get -y update
#
sudo echo "sudo apt-get -y upgrade"
sudo apt-get -y upgrade
#
sudo echo "sudo apt-get -y dist-upgrade"
sudo apt-get -y dist-upgrade
#
sudo echo "#..........................................."
sudo echo "#.......................Finish.............."
头像
astolia
论坛版主
帖子: 3305
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 554 次

Re: 是否可以恢復所有更新?

#2

帖子 astolia » 2018-11-07 10:13

アップデートマネージャーはapt-getと違います、その設定はapt-getに影響しません

ダウングレードは可能。ただし、システムの損傷のリスクも存在し、ダウングレードする前に重要なデータをバックアップする

まず、アップグレード履歴を/tmp にコピーします。

代码: 全选

cp /var/log/apt/history.log /tmp/
次に、/tmp/history.logを編集する、そのスクリプトを実行する前にすべての項目を削除する
その後、以下のコマンドを実行します

代码: 全选

apt install $(grep 'Upgrade' /tmp/history.log | sed 's/Upgrade://;s/ (/=/g;s/, \S*)//g;s/,/ /g') $(grep 'Install' /tmp/history.log | sed 's/Install://;s/ (\S*, \S*)/-/g;s/ (\S*)/-/g;s/,/ /g')
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#3

帖子 寺島聰子 » 2018-11-07 14:25

/tmp/history.logを編集する、そのスクリプトを実行する前にすべての項目を削除する
すべての項目を削除するとは、具体的に どう編集するのか、わかりません。
是刪除所有項目,具體如何修改,我不知道。
:Cry
Start-Date: 2018-11-02 19:45:20
Commandline: /usr/sbin/synaptic
Requested-By: maron (1000)
Install: python3-pyqt5.qtwebchannel:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5test5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5help5:i386 (5.9.5-0ubuntu1, automatic), python3-ruamel.yaml:i386 (0.15.34-1, automatic), python3-pyqt5.qtwebengine:i386 (5.10.1+dfsg-1ubuntu2, automatic), libminizip1:i386 (1.1-8build1, automatic), python3-pyqt5:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5sql5-sqlite:i386 (5.9.5+dfsg-0ubuntu1, automatic), python3-sip:i386 (4.19.7+dfsg-1, automatic), python3-pypeg2:i386 (2.15.2-2, automatic), libqt5webenginewidgets5:i386 (5.9.5+dfsg-0ubuntu2, automatic), libqt5xml5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5printsupport5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5qml5:i386 (5.9.5-0ubuntu1.1, automatic), libqt5quickwidgets5:i386 (5.9.5-0ubuntu1.1, automatic), libre2-4:i386 (20180201+dfsg-2, automatic), libqt5webchannel5:i386 (5.9.5-0ubuntu1, automatic), libqt5webengine-data:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-markupsafe:i386 (1.0-1build1, automatic), python3-pyqt5.qtquick:i386 (5.10.1+dfsg-1ubuntu2, automatic), python3-pyqt5.qtsql:i386 (5.10.1+dfsg-1ubuntu2, automatic), qutebrowser:i386 (1.1.1-1ubuntu0.1), python3-pyqt5.qtopengl:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5opengl5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5webenginecore5:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-pygments:i386 (2.2.0+dfsg-1, automatic), libqt5webengine5:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-jinja2:i386 (2.10-1, automatic), libqt5designer5:i386 (5.9.5-0ubuntu1, automatic), libqt5positioning5:i386 (5.9.5+dfsg-0ubuntu2, automatic), libqt5quick5:i386 (5.9.5-0ubuntu1.1, automatic), libqt5sql5:i386 (5.9.5+dfsg-0ubuntu1, automatic), python3-attr:i386 (17.4.0-2, automatic)
End-Date: 2018-11-02 19:46:04

Start-Date: 2018-11-05 12:18:50
Commandline: /usr/sbin/synaptic
Requested-By: maron (1000)
Install: gnome-font-viewer:i386 (3.28.0-1)
End-Date: 2018-11-05 12:18:59

Start-Date: 2018-11-06 23:57:38
Commandline: apt-get autoremove
Remove: libfltk1.1:i386 (1.1.10-23), python-webkit:i386 (1.1.8-3.1+peppermint9.0.0.0), python-chardet:i386 (3.0.4-1), python-beautifulsoup:i386 (3.2.1-1), python-olefile:i386 (0.45.1-1), python-pkg-resources:i386 (39.0.1-2), python-pil:i386 (5.1.0-1)
End-Date: 2018-11-06 23:57:49
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 是否可以恢復所有更新?

#4

帖子 xenomorph0525 » 2018-11-07 17:06

そもそも、なんでバージョンアップさせないんですか?
もしバージョンアップさせたくないパッケージがあれば、下記のコマンドができます:

sudo apt-mark hold パッケージ

解除するとき:

sudo apt-mark unhold パッケージ
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#5

帖子 寺島聰子 » 2018-11-07 20:50

そもそも、なんでバージョンアップさせないんですか?
OSの肥大化が いやだからです。そしてまた 使いもしない機能がアップデートされるのが いやだからです。
這是因為我不喜歡膨脹的操作系統。 我不喜歡更新我不喜歡的功能。
http://baker-street.jugem.jp/?eid=723(日文)

Linux Mint的更新管理器的初始設置也是Linux Mint的一個特性,但考慮到穩定性,它是一個相當謹慎的設置。 Linux Mint開發人員在這方面做得很好,我們正在進行質量質量控制並添加保護層。

Linux Mint將級別系統應用於更新。 級別從1到5,級別越高,風險越高。 默認情況下會顯示分類為級別1到3的更新並進行檢查。 顯示級別4,但默認情況下不進行檢查。 關於級別5的更新,即使默認也設置為不顯示。

デュアルブートしているmint17.2と同じにしようと思い、peppermint9 でもレベル 1 から 3 までだけをインストールしたかった。だから、最初からやり直したかった。
I tried to make it the same as mint 17.2 which is dual booting, and wanted to install only levels 1 to 3 on peppermint 9. So, I wanted to start over from the beginning.
头像
astolia
论坛版主
帖子: 3305
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 554 次

Re: 是否可以恢復所有更新?

#6

帖子 astolia » 2018-11-07 20:57

寺島聰子 写了:
2018-11-07 14:25
Start-Date: 2018-11-02 19:45:20
Commandline: /usr/sbin/synaptic
Requested-By: maron (1000)
Install: python3-pyqt5.qtwebchannel:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5test5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5help5:i386 (5.9.5-0ubuntu1, automatic), python3-ruamel.yaml:i386 (0.15.34-1, automatic), python3-pyqt5.qtwebengine:i386 (5.10.1+dfsg-1ubuntu2, automatic), libminizip1:i386 (1.1-8build1, automatic), python3-pyqt5:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5sql5-sqlite:i386 (5.9.5+dfsg-0ubuntu1, automatic), python3-sip:i386 (4.19.7+dfsg-1, automatic), python3-pypeg2:i386 (2.15.2-2, automatic), libqt5webenginewidgets5:i386 (5.9.5+dfsg-0ubuntu2, automatic), libqt5xml5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5printsupport5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5qml5:i386 (5.9.5-0ubuntu1.1, automatic), libqt5quickwidgets5:i386 (5.9.5-0ubuntu1.1, automatic), libre2-4:i386 (20180201+dfsg-2, automatic), libqt5webchannel5:i386 (5.9.5-0ubuntu1, automatic), libqt5webengine-data:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-markupsafe:i386 (1.0-1build1, automatic), python3-pyqt5.qtquick:i386 (5.10.1+dfsg-1ubuntu2, automatic), python3-pyqt5.qtsql:i386 (5.10.1+dfsg-1ubuntu2, automatic), qutebrowser:i386 (1.1.1-1ubuntu0.1), python3-pyqt5.qtopengl:i386 (5.10.1+dfsg-1ubuntu2, automatic), libqt5opengl5:i386 (5.9.5+dfsg-0ubuntu1, automatic), libqt5webenginecore5:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-pygments:i386 (2.2.0+dfsg-1, automatic), libqt5webengine5:i386 (5.9.5+dfsg-0ubuntu2, automatic), python3-jinja2:i386 (2.10-1, automatic), libqt5designer5:i386 (5.9.5-0ubuntu1, automatic), libqt5positioning5:i386 (5.9.5+dfsg-0ubuntu2, automatic), libqt5quick5:i386 (5.9.5-0ubuntu1.1, automatic), libqt5sql5:i386 (5.9.5+dfsg-0ubuntu1, automatic), python3-attr:i386 (17.4.0-2, automatic)
End-Date: 2018-11-02 19:46:04

Start-Date: 2018-11-05 12:18:50
Commandline: /usr/sbin/synaptic
Requested-By: maron (1000)
Install: gnome-font-viewer:i386 (3.28.0-1)
End-Date: 2018-11-05 12:18:59

Start-Date: 2018-11-06 23:57:38
Commandline: apt-get autoremove
Remove: libfltk1.1:i386 (1.1.10-23), python-webkit:i386 (1.1.8-3.1+peppermint9.0.0.0), python-chardet:i386 (3.0.4-1), python-beautifulsoup:i386 (3.2.1-1), python-olefile:i386 (0.45.1-1), python-pkg-resources:i386 (39.0.1-2), python-pil:i386 (5.1.0-1)
End-Date: 2018-11-06 23:57:49
apt-get upgrade/dist-upgradeを実行してシステムを更新していないようです、ダウングレードを実行する必要はありません
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 是否可以恢復所有更新?

#7

帖子 xenomorph0525 » 2018-11-07 21:10

寺島聰子 写了:
2018-11-07 20:50
OSの肥大化が いやだからです。そしてまた 使いもしない機能がアップデートされるのが いやだからです。
這是因為我不喜歡膨脹的操作系統。 我不喜歡更新我不喜歡的功能。

アップデート前後のOSサイズはあまり変化しませんよ。
大きくなってくるのはダウンロードしておいたdebファイルのせいです。
OSを痩せさせたいなら、

sudo apt autoremove --purge
sudo apt clean

そして、Ubuntu Cleanerを使って、いらないものを削除してみて:

sudo add-apt-repository ppa:gerardpuig/ppa
sudo apt update
sudo apt install ubuntu-cleaner
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#8

帖子 寺島聰子 » 2018-11-09 20:29

返事が遅く、ご無礼をお許しください。
答复很晚,請原諒我粗魯。

~$ sudo apt autoremove --purge
[sudo] password for maron:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
~$ sudo apt clean
~$

このコマンドをデュアルブートしているmint 17.2 上で実行しますと

$ sudo apt autoremove --purge
[sudo] password for m:
E: コマンドラインオプション --purge を理解できません
$
となります。どうすれば よいですか?. What should I do?

Ubuntu Cleaner ありがとうございました非常感谢你
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 是否可以恢復所有更新?

#9

帖子 xenomorph0525 » 2018-11-09 21:18

寺島聰子 写了:
2018-11-09 20:29

このコマンドをデュアルブートしているmint 17.2 上で実行しますと

$ sudo apt autoremove --purge
[sudo] password for m:
E: コマンドラインオプション --purge を理解できません
$
となります。どうすれば よいですか?. What should I do?
なんか変です。そんなはずがないと思います……
どうして???

では、「sudo apt autoremove」を使ってみてください。

でもどうして「--purge」はだめなの???
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#10

帖子 寺島聰子 » 2018-11-10 0:17

mint17.2 

$ sudo apt autoremove
[sudo] password for m:
E: 不正な操作 autoremove
$
:Cry
$ export LANG=en_US
$ sudo apt autoremove --purge
[sudo] password for m:
E: Command line option --purge is not understood
$ sudo apt autoremove
E: Invalid operation autoremove

$
https://askubuntu.com/questions/573624/ ... -apt-alias

>As of Ubuntu 14.10, apt is a program installed on the system. It does not currently support autoremove.

$ sudo apt-get autoremove --purge
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 82 not upgraded.
$
:Haha
xenomorph0525様、ありがとうございました!谢谢
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#11

帖子 寺島聰子 » 2018-11-10 0:27

xenomorph0525 写了:
2018-11-07 17:06
そもそも、なんでバージョンアップさせないんですか?
もしバージョンアップさせたくないパッケージがあれば、下記のコマンドができます:

sudo apt-mark hold パッケージ
$ sudo apt-mark hold firefox
[sudo] password for m:
firefox は保留に設定されました。
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package gdb-minimal
W: Ignoring Provides line with DepCompareOp for package gdb-minimal
W: これらの問題を解決するためには apt-get update を実行する必要があるかもしれません
$
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 是否可以恢復所有更新?

#12

帖子 xenomorph0525 » 2018-11-10 14:41

寺島聰子 写了:
2018-11-10 0:27

$ sudo apt-mark hold firefox
[sudo] password for m:
firefox は保留に設定されました。
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package gdb-minimal
W: Ignoring Provides line with DepCompareOp for package gdb-minimal
W: これらの問題を解決するためには apt-get update を実行する必要があるかもしれません
$
Firefoxをバージョンアップさせたくないんですか?
でもそうすると、セキュリティのリスクがありますよ。

バージョンアップさせたくない場合はFirefox ESRを使うはうがいいと思います。
https://www.mozilla.org/en-US/firefox/organizations/

sudo add-apt-repository ppa:mozillateam/ppa
sudo apt-get update
sudo sudo apt-get install firefox-esr firefox-esr-locale-en firefox-esr-locale-ja
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#13

帖子 寺島聰子 » 2018-11-11 5:36

~$ sudo apt-mark unhold firefox
[sudo] password for maron:
Canceled hold on firefox.
~$
Firefoxをバージョンアップさせたくないんですか?
Do not you want to upgrade Firefox?
次のバージョンのFirefoxはひじょうに重いと聞きましたので。
因為我聽說Firefox的下一個版本很重。
でもそうすると、セキュリティのリスクがありますよ。
但是你有安全隱患
安全隱患とは具体的にどういう危険なのか まったくイメージがわかないのです。ですから、old version のブラウザを使いたくなるのです。
我根本不知道安全隱患具體是什麼樣的風險。 所以,我想使用舊版瀏覽器。
バージョンアップさせたくない場合はFirefox ESRを使うはうがいいと思います。
https://www.mozilla.org/en-US/firefox/organizations/
ありがとうございました。でも 私の求めるものと違うと思いました。これは最新の重いFirefoxと同じベースだろうと推測しました。
非常感謝你。 但我認為這與我想要的不同。 我猜這將是與最新的重型Firefox相同的基礎。

フォーラムの どこに書き込むべきか わからないのですが、slimjet 舊版瀏覽器をインストールしたいと考えているのですが。
我不知道在哪裡寫論壇,我想安裝舊版slimjet。
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 是否可以恢復所有更新?

#14

帖子 xenomorph0525 » 2018-11-11 12:40

寺島聰子 写了:
2018-11-11 5:36
次のバージョンのFirefoxはひじょうに重いと聞きましたので。
因為我聽說Firefox的下一個版本很重。
次のバージョンのFirefoxとは何版ですか?
もし62→63なら、確かにそうです。わたしもそう感じます。

でもFireox → Fireox Quantum なら、Fireox Quantum方が明らかに早いですよ。
つまりこういう感じ:「57~62」 > 「63以上」 > 「56以下」。

Fireox ESR 60 を勧めます。

寺島聰子 写了:
2018-11-11 5:36
フォーラムの どこに書き込むべきか わからないのですが、slimjet 舊版瀏覽器をインストールしたいと考えているのですが。
我不知道在哪裡寫論壇,我想安裝舊版slimjet。
Slimjet はdebファイルがあるけど、舊版はどこにあるか、私もあまり分かりません…
https://www.slimjet.com/en/dlpage.php
寺島聰子
帖子: 354
注册时间: 2016-06-03 14:39
系统: Peppermint9 32bit
送出感谢: 1 次
接收感谢: 1 次

Re: 是否可以恢復所有更新?

#15

帖子 寺島聰子 » 2018-11-13 1:58

Fireox ESR 60 を勧めます。
元のFirefoxを削除しました。
我删除了原来的Firefox。
(データベースを読み込んでいます ... 現在 316145 個のファイルとディレクトリがインストールされています。)
firefox (63.0+build2-0ubuntu0.18.04.2) を削除しています ...
mime-support (3.60ubuntu1) のトリガを処理しています ...
desktop-file-utils (0.23-1ubuntu3.18.04.1) のトリガを処理しています ...
man-db (2.8.3-2ubuntu0.1) のトリガを処理しています ...
gnome-menus (3.13.3-11ubuntu1.1) のトリガを処理しています ...
hicolor-icon-theme (0.17-2) のトリガを処理しています ...
peppermint-system (9.0.1.1) のトリガを処理しています ...
(データベースを読み込んでいます ... 現在 316049 個のファイルとディレクトリがインストールされています。)
firefox (63.0+build2-0ubuntu0.18.04.2) の設定ファイルを削除しています ...

https://support.mozilla.org/zh-TW/kb/in ... efox-linux

從 Firefox 下載頁面 中把下載 Firefox 到你的家目錄中。
開啟 終端機 並切換至您的家目錄: cd ~
解開下載的壓縮檔內容: tar xjf firefox-*.tar.bz2
若 Firefox 正在執行,請先關閉。
要啟動 Firefox,請執行位於 firefox 資料夾中的 firefox 指令碼 ~/firefox/firefox

現在 Firefox 應該已經啟動,你可以於桌面建立捷徑去執行上述指令。

你可以於桌面建立捷徑去執行上述指令」このやり方がわかりません。我不知道這種方式。
私は 右クリック>リンクの作成>リンクを右クリック>指定先に移動>デスクトップ
アイコンの画像が以下の様になりました。正しい狐のアイコンがどこにあるかわかりません。起動は問題ないです。
我右鍵單擊>創建鏈接>右鍵單擊鏈接>移動到目標>桌面
圖標的圖像現在如下。 我不知道正確的狐狸圖標在哪裡。 啟動是沒有問題的。
附件
スクリーンショット_2018-11-13_02-53-41.png
スクリーンショット_2018-11-13_02-53-41.png (3.21 KiB) 查看 237 次
回复

回到 “Ubuntu 18.04 LTS”