求问No supported Python (2.4 / 2.6 / 2.7) version available.?

回复
风动帆起
帖子: 2
注册时间: 2015-01-27 22:28
系统: mint
送出感谢: 1 次
接收感谢: 0

求问No supported Python (2.4 / 2.6 / 2.7) version available.?

#1

帖子 风动帆起 » 2015-01-27 22:36

终端第一行出现No supported Python (2.4 / 2.6 / 2.7) version available.是怎么回事?
求问,好像也没什么影响,但是看着不爽
poloshiao
论坛版主
帖子: 18006
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1914 次

Re: 求问No supported Python (2.4 / 2.6 / 2.7) version availabl

#2

帖子 poloshiao » 2015-01-28 7:39

No supported Python (2.4 / 2.6 / 2.7) version available
把下面指令 複製 貼進終端機 執行
1. uname -r
2. sudo dpkg -l | grep python2.
把結果直接 選取/複製 貼上來
不必擷圖
这些用户感谢了作者 poloshiao 于这个帖子:
风动帆起 (2015-01-28 11:57)
评价: 3.7%
jinjiachen
帖子: 2095
注册时间: 2012-12-16 15:43
系统: debian
送出感谢: 8 次
接收感谢: 27 次

Re: 求问No supported Python (2.4 / 2.6 / 2.7) version availabl

#3

帖子 jinjiachen » 2015-01-28 8:02

意思是你没有支持的python,
风动帆起
帖子: 2
注册时间: 2015-01-27 22:28
系统: mint
送出感谢: 1 次
接收感谢: 0

Re: 求问No supported Python (2.4 / 2.6 / 2.7) version availabl

#4

帖子 风动帆起 » 2015-01-28 11:56

poloshiao 写了:
No supported Python (2.4 / 2.6 / 2.7) version available
把下面指令 複製 貼進終端機 執行
1. uname -r
2. sudo dpkg -l | grep python2.
把結果直接 選取/複製 貼上來
不必擷圖
3.13.0-37-generic
ii idle-python2.7 2.7.6-8 all IDE for Python (v2.7) using Tkinter
ii libpython2.7:amd64 2.7.6-8 amd64 Shared Python runtime library (version 2.7)
ii libpython2.7-dbg:amd64 2.7.6-8 amd64 Debug Build of the Python Interpreter (version 2.7)
ii libpython2.7-dev:amd64 2.7.6-8 amd64 Header files and a static library for Python (v2.7)
ii libpython2.7-minimal:amd64 2.7.6-8 amd64 Minimal subset of the Python language (version 2.7)
ii libpython2.7-stdlib:amd64 2.7.6-8 amd64 Interactive high-level object-oriented language (standard library, version 2.7)
ii libpython2.7-testsuite 2.7.6-8 all Testsuite for the Python standard library (v2.7)
ii python2.7 2.7.6-8 amd64 Interactive high-level object-oriented language (version 2.7)
ii python2.7-dbg 2.7.6-8 amd64 Debug Build of the Python Interpreter (version 2.7)
ii python2.7-dev 2.7.6-8 amd64 Header files and a static library for Python (v2.7)
ii python2.7-doc 2.7.6-8 all Documentation for the high-level object-oriented language Python (v2.7)
ii python2.7-minimal 2.7.6-8 amd64 Minimal subset of the Python language (version 2.7)
谢谢
poloshiao
论坛版主
帖子: 18006
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1914 次

Re: 求问No supported Python (2.4 / 2.6 / 2.7) version availabl

#5

帖子 poloshiao » 2015-01-28 13:05

ii python2.7 2.7.6-8 amd64 Interactive high-level object-oriented language (version 2.7)
表示 你已安裝 python2.7

sudo ls -al /usr/bin/python
看看 有沒有軟連結到 python2.7
lrwxrwxrwx 1 root root 9 12月 21 2013 /usr/bin/python -> python2.7

如果沒有
sudo update-alternatives --config python
回复

回到 “Mint”