如何安装unity8?

讨论openbox,awesome,FVWM等WM
回复
xfcy
帖子: 113
注册时间: 2011-11-26 12:07
送出感谢: 1 次
接收感谢: 0

如何安装unity8?

#1

帖子 xfcy » 2018-03-29 8:56

目前是KDE桌面,按网上的说法安装unity8,但是得到的结果是依赖关系无法满足,大意是已安装的部分软件包比依赖的软件包新。这种情况该如何处理呢?
poloshiao
论坛版主
帖子: 18174
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 如何安装unity8?

#2

帖子 poloshiao » 2018-03-29 11:12

按网上的说法安装unity8
請提供該说法的網址
xfcy
帖子: 113
注册时间: 2011-11-26 12:07
送出感谢: 1 次
接收感谢: 0

Re: 如何安装unity8?

#3

帖子 xfcy » 2018-03-29 11:22

poloshiao 写了:
按网上的说法安装unity8
請提供該说法的網址
https://jingyan.baidu.com/article/72ee5 ... 8dfee.html
poloshiao
论坛版主
帖子: 18174
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 如何安装unity8?

#4

帖子 poloshiao » 2018-03-29 11:44

目前是 KDE 桌面
1. 該網頁是 基於 Ubuntu 16.04

2. Ubuntu 16.04 預設是 unity7 桌面
2-1. 意思是 KDE 桌面 與 unity7 桌面 差異極大 已安裝的套件及相依套件 差異很大
2-2. 如果你要參考該網頁 建議你
2-2-1. 先安裝 ubuntu-desktop 套件 (參見 3-2)
2-2-2. 重開機 登入密碼的地方 選擇登入 ubuntu (即 unity) 桌面
2-2-3. 更新到最新版本 (參見 3-3)
2-2-4. 再重新開機 登入 ubuntu (即 unity) 再開始安裝 unity8

3. 參閱
3-1. https://packages.ubuntu.com/xenial/ubuntu-desktop
Package: ubuntu-desktop (1.361)
3-2. 安裝 ubuntu-desktop 套件
sudo apt install ubuntu-desktop
3-3. 更新
sudo apt update
sudo apt upgrade

4. 參閱
https://askubuntu.com/a/65108
xfcy
帖子: 113
注册时间: 2011-11-26 12:07
送出感谢: 1 次
接收感谢: 0

Re: 如何安装unity8?

#5

帖子 xfcy » 2018-03-29 18:29

poloshiao 写了:
目前是 KDE 桌面
1. 該網頁是 基於 Ubuntu 16.04

2. Ubuntu 16.04 預設是 unity7 桌面
2-1. 意思是 KDE 桌面 與 unity7 桌面 差異極大 已安裝的套件及相依套件 差異很大
2-2. 如果你要參考該網頁 建議你
2-2-1. 先安裝 ubuntu-desktop 套件 (參見 3-2)
2-2-2. 重開機 登入密碼的地方 選擇登入 ubuntu (即 unity) 桌面
2-2-3. 更新到最新版本 (參見 3-3)
2-2-4. 再重新開機 登入 ubuntu (即 unity) 再開始安裝 unity8

3. 參閱
3-1. https://packages.ubuntu.com/xenial/ubuntu-desktop
Package: ubuntu-desktop (1.361)
3-2. 安裝 ubuntu-desktop 套件
sudo apt install ubuntu-desktop
3-3. 更新
sudo apt update
sudo apt upgrade

[email protected]:/home/admin-x# sudo apt install ubuntu-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
ubuntu-desktop : 依赖: language-selector-gnome 但是它将不会被安装
依赖: nautilus 但是它将不会被安装
依赖: software-properties-gtk 但是它将不会被安装
依赖: ubuntu-release-upgrader-gtk 但是它将不会被安装
依赖: update-manager 但是它将不会被安装
依赖: update-notifier
推荐: bluez-cups 但是它将不会被安装
推荐: cups
推荐: gvfs-fuse 但是它将不会被安装
推荐: hplip 但是它将不会被安装
推荐: libproxy1-plugin-gsettings 但是它将不会被安装
推荐: libproxy1-plugin-networkmanager 但是它将不会被安装
推荐: libreoffice-gnome 但是它将不会被安装
推荐: libreoffice-ogltrans 但是它将不会被安装
推荐: nautilus-share 但是它将不会被安装
推荐: plymouth-theme-ubuntu-logo 但是它将不会被安装
推荐: printer-driver-splix 但是它将不会被安装
推荐: ubuntu-software 但是它将不会被安装
推荐: unity8-desktop-session 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
[email protected]:/home/admin-x#
poloshiao
论坛版主
帖子: 18174
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 如何安装unity8?

#6

帖子 poloshiao » 2018-03-29 19:08

sudo apt install ubuntu-desktop
忘了跟你提醒
養成習慣 安裝任何套件前 先把你的系統 更新到最新版本狀態 比較不會碰到 相依套件無法安裝的問題

sudo apt update
sudo apt upgrade
sudo systemctl reboot
sudo apt install ubuntu-desktop

如果還有問題 可能是受到你已不完整安裝 unity8 的影響
請把 失敗或錯誤訊息 全部複製 貼上來
xfcy
帖子: 113
注册时间: 2011-11-26 12:07
送出感谢: 1 次
接收感谢: 0

Re: 如何安装unity8?

#7

帖子 xfcy » 2018-03-29 20:46

poloshiao 写了:
sudo apt install ubuntu-desktop
忘了跟你提醒
養成習慣 安裝任何套件前 先把你的系統 更新到最新版本狀態 比較不會碰到 相依套件無法安裝的問題

sudo apt update
sudo apt upgrade
sudo systemctl reboot
sudo apt install ubuntu-desktop

如果還有問題 可能是受到你已不完整安裝 unity8 的影響
請把 失敗或錯誤訊息 全部複製 貼上來
[email protected]:/home/admin-x# sudo apt install ubuntu-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libavutil55 : 破坏: libavfilter6 (< 7:3.4) 但是 7:3.2.4-1build2 正要被安装
ubuntu-desktop : 依赖: gdm3 但是它将不会被安装
依赖: gnome-control-center 但是它将不会被安装
依赖: gnome-shell 但是它将不会被安装
依赖: gstreamer1.0-packagekit 但是它将不会被安装
依赖: language-selector-gnome 但是它将不会被安装
依赖: nautilus 但是它将不会被安装
依赖: software-properties-gtk 但是它将不会被安装
依赖: ubuntu-release-upgrader-gtk 但是它将不会被安装
依赖: ubuntu-session 但是它将不会被安装
依赖: update-manager 但是它将不会被安装
依赖: update-notifier
推荐: brltty 但是它将不会被安装
推荐: gnome-disk-utility 但是它将不会被安装
推荐: gnome-software-plugin-snap 但是它将不会被安装
推荐: gvfs-fuse 但是它将不会被安装
推荐: ibus
推荐: ibus-table 但是它将不会被安装
推荐: nautilus-share 但是它将不会被安装
推荐: network-manager 但是它将不会被安装
推荐: network-manager-config-connectivity-ubuntu 但是它将不会被安装
推荐: network-manager-pptp-gnome 但是它将不会被安装
推荐: packagekit
推荐: plymouth-theme-ubuntu-logo 但是它将不会被安装
推荐: shotwell 但是它将不会被安装
推荐: snapd 但是它将不会被安装
推荐: ubuntu-software 但是它将不会被安装
推荐: usb-creator-gtk 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
poloshiao
论坛版主
帖子: 18174
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 如何安装unity8?

#8

帖子 poloshiao » 2018-03-30 11:20

先解決這個問題
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
1. 參閱
https://askubuntu.com/a/831434
Ubuntu 16.04
libavutil55 : 破坏: libavfilter6 (< 7:3.4) 但是 7:3.2.4-1build2 正要被安装
2. Ubuntu 16.04 官方套件庫 並沒有 libavutil55 及 libavfilter6 ? 哪來的 相依套件關係 ?
2-1. https://packages.ubuntu.com/search?suit ... chon=names
Package libavutil55
2-2. https://packages.ubuntu.com/search?suit ... chon=names
Package libavfilter6
回复

回到 “窗口管理器”