当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : "aptitude why 未安装包"的结果是什么?难道是未定义行为吗?
帖子发表于 : 2017-11-21 16:03 

注册: 2013-05-26 6:58
帖子: 2212
系统: Debian 9
送出感谢: 910
接收感谢: 32
"aptitude why 未安装包"的结果是什么?难道是未定义行为吗?


_________________
Linux桌面优化综合贴[2017.09.18](欢迎各位补充或指正误区)
[2016.03.10]会C语言但看不懂英文文档的点这里,一个用C语言编写的简陋学习工具
单硬盘通过iso文件实机安装Debian的方法
重启或操作fcitx时失去响应的一个解决方法,不妨试试看


页首
 用户资料  
 
2 楼 
 文章标题 : Re: "aptitude why 未安装包"的结果是什么?难道是未定义行为吗?
帖子发表于 : 2017-11-21 16:20 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
代码:
0 ~ $ aptitude why 0ad-data
Not currently installed
The candidate version 0.0.21-1 has priority optional
No dependencies require to install 0ad-data

1 ~ $ aptitude --version
aptitude 0.8.7

0 ~ $ cat /etc/issue
Debian GNU/Linux 9 \n \l


老版的话,输出的不是搜索过程么 http://paste.ubuntu.com/26010808/

[编辑] 忘了之前设置过 Aptitude::CmdLine::Verbose "2"; 在 /etc/apt/apt.conf 中,所以输出了搜索过程。恢复默认设定后,只会输出一行 Unable to find a reason to install 0ad-data.


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户



_________________
评价: 3.7% 科学之子
 
页首
 用户资料  
 
3 楼 
 文章标题 : Re: "aptitude why 未安装包"的结果是什么?难道是未定义行为吗?
帖子发表于 : 2017-11-21 23:45 

注册: 2013-05-26 6:58
帖子: 2212
系统: Debian 9
送出感谢: 910
接收感谢: 32
vickycq 写道:
代码:
0 ~ $ aptitude why 0ad-data
Not currently installed
The candidate version 0.0.21-1 has priority optional
No dependencies require to install 0ad-data

1 ~ $ aptitude --version
aptitude 0.8.7

0 ~ $ cat /etc/issue
Debian GNU/Linux 9 \n \l


老版的话,输出的不是搜索过程么 http://paste.ubuntu.com/26010808/

[编辑] 忘了之前设置过 Aptitude::CmdLine::Verbose "2"; 在 /etc/apt/apt.conf 中,所以输出了搜索过程。恢复默认设定后,只会输出一行 Unable to find a reason to install 0ad-data.


用debootstrap安装的全新基本系统测试结果如下:
代码:
[email protected]:/# aptitude show termit |grep '^State'
State: not installed
[email protected]:/# aptitude why termit
i   cron            Recommends exim4 | postfix | mail-transport-agent
p   courier-mta     Provides   mail-transport-agent                 
p   courier-mta     Depends    courier-authlib (>= 0.66.4-5~)       
p   courier-authlib Recommends expect                               
p   expect          Recommends tk8.6                                 
p   tk8.6           Recommends xterm | x-terminal-emulator           
p   termit          Provides   x-terminal-emulator                   
[email protected]:/# aptitude --version
aptitude 0.8.7
Compiler: g++ 6.3.0 20170415
Compiled against:
  apt version 5.0.1
  NCurses version 6.0
  libsigc++ version: 2.10.0
  Gtk+ support disabled.
  Qt support disabled.

Current library versions:
  NCurses version: ncurses 6.0.20161126
  cwidget version: 0.5.17
  Apt version: 5.0.1
[email protected]:/# cat /etc/os-release |grep '^PRETTY'
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
[email protected]:/# aptitude show 0ad-data |grep '^State'
State: not installed
[email protected]:/# aptitude why 0ad-data
Not currently installed
The candidate version 0.0.21-1 has priority optional
No dependencies require to install 0ad-data
[email protected]:/#

还有"aptitude why openbox"也会出现一堆不知所云的依赖关系.


_________________
Linux桌面优化综合贴[2017.09.18](欢迎各位补充或指正误区)
[2016.03.10]会C语言但看不懂英文文档的点这里,一个用C语言编写的简陋学习工具
单硬盘通过iso文件实机安装Debian的方法
重启或操作fcitx时失去响应的一个解决方法,不妨试试看


页首
 用户资料  
 
4 楼 
 文章标题 : Re: "aptitude why 未安装包"的结果是什么?难道是未定义行为吗?
帖子发表于 : 2017-11-23 21:07 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
诶,还真是这样。不过这些“假想”依赖链看上去并没有问题,由于里面没有“硬”依赖,才没有真的安装。(都涉及到 Recommend 或虚包(virtual package))

是不是可以理解成:由于 aptitude 可以解析出这样一条“依赖”链,如果我们现在安装 termit,即使将其标记为自动安装也无法被 autoremove

代码:
$ aptitude why termit
i   winff-gtk2 Depends  xterm | x-terminal-emulator
p   termit     Provides x-terminal-emulator


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户



_________________
评价: 3.7% 科学之子
 
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译