[已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

最大的社区版本,Ubuntu的发源地
回复
科学之子
帖子: 2250
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 839 次
接收感谢: 30 次

[已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

#1

帖子 科学之子 » 2017-09-14 13:03

[已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?
具体原理是怎么回事?同样的耳机,只是坏了换了个相同的耳机就不认识了?
之前还好好的.

快速解决方案(多声卡可能需要调整index(就是那个数字)):
echo >> set-sink-port 0 analog-output-headphones
来源: https://unix.stackexchange.com/question ... headphones
搜索结果链接
上次由 科学之子 在 2017-09-14 23:13,总共编辑 1 次。
科学之子
帖子: 2250
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 839 次
接收感谢: 30 次

Re: [已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

#2

帖子 科学之子 » 2017-09-14 19:17

:Aadterboom
调试了半天default.pa 感觉莫名其妙好了...
甚至最后删掉etc和home的配置文件然后

代码: 全选

sudo aptitude -o Dpkg::Options::="--force-confmiss" reinstall pulseaudio
也还是一样,说明默认配置真的没问题...
难道是硬件问题?耳机问题还是主板接口的问题?如何判断?
头像
astolia
论坛版主
帖子: 3144
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 527 次

Re: [已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

#4

帖子 astolia » 2017-09-14 20:45

你确定是“相同”耳机?拆开检查过芯片型号?核对过固件版本?
科学之子
帖子: 2250
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 839 次
接收感谢: 30 次

Re: [已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

#5

帖子 科学之子 » 2017-09-14 21:20

astolia 写了:你确定是“相同”耳机?拆开检查过芯片型号?核对过固件版本?
这方面我纯小白,个人感觉十几元的耳机还能有"固件"和"芯片"?感觉就是个声卡供电的小喇叭...
感觉类似这种东西
我这个耳机=磁铁+线圈+震膜+导线+变阻器+塑料壳
Thu Sep 14 21:26:50 CST 2017补充:
刚搜了一下,像样的名字叫动圈耳机.
onlylove
论坛版主
帖子: 4428
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 99 次

Re: [已解决但不明白]相同耳机坏掉找卖家换货后pulseaudio就无法自动识别port了?

#6

帖子 onlylove » 2017-09-14 22:24

科学之子 写了:
astolia 写了:你确定是“相同”耳机?拆开检查过芯片型号?核对过固件版本?
这方面我纯小白,个人感觉十几元的耳机还能有"固件"和"芯片"?感觉就是个声卡供电的小喇叭...
感觉类似这种东西
我这个耳机=磁铁+线圈+震膜+导线+变阻器+塑料壳
Thu Sep 14 21:26:50 CST 2017补充:
刚搜了一下,像样的名字叫动圈耳机.
他说的可能是那种usb接口的(3.5接口的不是很清楚,那种主动降噪的,应该有降噪算法什么的……不过应该不用驱动吧)
这些用户感谢了作者 onlylove 于这个帖子:
科学之子 (2017-09-14 22:36)
评价: 3.7%
回复

回到 “Debian发行版”