我的unbuntu安装不了wine,各位大神帮忙看下怎么解决

Wine、Cedega、CrossOver 等配置
回复
agdwzj
帖子: 2
注册时间: 2018-01-22 11:16
系统: unbuntu14.04
送出感谢: 0
接收感谢: 0

我的unbuntu安装不了wine,各位大神帮忙看下怎么解决

#1

帖子 agdwzj » 2018-01-22 12:45

1. 输入sudo add-apt-repository ppa:ubuntu-wine/ppa

!!! PLEASE NOTE THAT THIS REPOSITORY IS DEPRECATED !!!

In fact, it's double deprecated -- it was replaced by the Wine Builds PPA, which was then itself replaced.

For more information, please see:

https://www.winehq.org/pipermail/wine-d ... 17104.html

The following commands can be used to add the new repository:

wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
More info: https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmph85cijst/secring.gpg' created
gpg: keyring `/tmp/tmph85cijst/pubring.gpg' created
gpg: requesting key F9CB8DB0 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmph85cijst/trustdb.gpg: trustdb created
gpg: key F9CB8DB0: public key "Launchpad PPA for Ubuntu Wine Team" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK

2. 输入sudo apt-get update

Hit:1 http://192.168.67.7/cn.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://192.168.67.7/cn.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://192.168.67.7/cn.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 http://cn.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty InRelease
Hit:6 https://dl.winehq.org/wine-builds/ubuntu trusty InRelease
Reading package lists... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: http://ppa.launchpad.net/ubuntu-wine/pp ... /InRelease: Signature by key 883E8688397576B6C509DF495A9A06AEF9CB8DB0 uses weak digest algorithm (SHA1)
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:8

3. 输入sudo apt-get install wine

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsoup2.4-1 : Depends: glib-networking (>= 2.32.0) but it is not going to be installed
ubuntu-system-settings : Depends: qtdeclarative5-ubuntu-settings-components (> 0.7+15.04.20160310) but it is not going to be installed
Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin (>= 1.3.1584) or
qtdeclarative5-ubuntu-ui-toolkit-plugin-gles (>= 1.3.1584) but it is not going to be installed
Depends: ubuntu-keyboard-data (>= 0.99.trunk.phablet2+15.04.20150421) but it is not going to be installed
ubuntu-system-settings-online-accounts : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin or
qtdeclarative5-ubuntu-ui-toolkit-plugin-gles but it is not going to be installed
udev : Breaks: plymouth (< 0.9.0-7) but 0.8.8-0ubuntu17.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
poloshiao
论坛版主
帖子: 18179
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 我的unbuntu安装不了wine,各位大神帮忙看下怎么解决

#2

帖子 poloshiao » 2018-01-22 13:20

!!! PLEASE NOTE THAT THIS REPOSITORY IS DEPRECATED !!!
請說明 你的 ubuntu 版本 及 你要安裝的 Wine 詳細版本
agdwzj
帖子: 2
注册时间: 2018-01-22 11:16
系统: unbuntu14.04
送出感谢: 0
接收感谢: 0

Re: 我的unbuntu安装不了wine,各位大神帮忙看下怎么解决

#3

帖子 agdwzj » 2018-01-22 13:54

@poloshiao
版本号是:Ubuntu 14.04.5 LTS
对Wine版本没要求,只要能运行SourceInsight和Notepad++就行了。
poloshiao
论坛版主
帖子: 18179
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 我的unbuntu安装不了wine,各位大神帮忙看下怎么解决

#4

帖子 poloshiao » 2018-01-22 19:14

版本号是:Ubuntu 14.04.5 LTS
1. https://www.winehq.org/download
Wine Binary Packages
Latest stable release:
Wine 3.0

2. These packages are built and supported by WineHQ
Ubuntu - WineHQ binary packages for Ubuntu 14.04, 16.04, 16.10, 17.04, and 17.10
2-1. 依序安裝 不要遺漏
https://wiki.winehq.org/Ubuntu
Ubuntu
Installing WineHQ packages
回复

回到 “Wine及其分支”